Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 1 of 1
  1. #1
    Junior Member
    Join Date
    Jan 2010
    Posts
    1
    Member #
    20940
    Greetings!

    I am using flashvars in my OBJECT and EMBED tags like so:

    Code:
    <OBJECT codeBase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,40,0" classid=clsid:D27CDB6E-AE6D-11cf-96B8-444553540000 width=250 height=250>
    <PARAM NAME="_cx" VALUE="6614">
    <PARAM NAME="_cy" VALUE="10583">
    <PARAM NAME="Movie" VALUE="/images/flash/menu_flash.swf">
    <PARAM NAME="Src" VALUE="/images/flash/menu_flash.swf">
    <PARAM NAME="WMode" VALUE="Transparent">
    <param name="FlashVars" value="section=a_set" />
    <PARAM NAME="Play" VALUE="-1">
    <PARAM NAME="Loop" VALUE="-1">
    <PARAM NAME="Quality" VALUE="High">
    <PARAM NAME="SAlign" VALUE="">
    <PARAM NAME="Menu" VALUE="-1">
    <PARAM NAME="Base" VALUE="">
    <PARAM NAME="AllowScriptAccess" VALUE="">
    <PARAM NAME="Scale" VALUE="ShowAll">
    <PARAM NAME="DeviceFont" VALUE="0">
    <PARAM NAME="EmbedMovie" VALUE="0">
    <PARAM NAME="BGColor" VALUE="">
    <PARAM NAME="SWRemote" VALUE="">
    <PARAM NAME="MovieData" VALUE="">
    <PARAM NAME="SeamlessTabbing" VALUE="1">
    <PARAM NAME="Profile" VALUE="0">
    <PARAM NAME="ProfileAddress" VALUE="">
    <PARAM NAME="ProfilePort" VALUE="0">
    <PARAM NAME="AllowNetworking" VALUE="all">
    <PARAM NAME="AllowFullScreen" VALUE="false">
     
    <embed src="/images/flash/menu_flash.swf" width="250" height="250" play="true" loop="true" wmode="transparent" flashvars="section=a_set"  quality="high" align="" pluginspage="http://www.macromedia.com/go/getflashplayer"></embed>
    </OBJECT>
    From there, in my actionscript, I have movie clips acting as menu buttons, all placed in one frame in each layer. The first frame on the top layer uses contains a blank keyframe and the following actionscript:

    Code:
    _root.availability.availability_anim.gotoAndStop(section);
    Each layer after that contains an instance (in this example, the instance is named "availability", which is the text of the button), that instance contains the button in an off state and and on state, and the on state contains the instance "availability_anim". In the movie clip this instance represents, there is a frame labeled "a_set".

    The idea is that if once goes to availability.php?section=a_set, it should display the rollover state of the button exactly at the label, a_set, but it doesn't.

    Any suggestions would be appreciated.

  2.  


Remove Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 08:45 PM.
Powered by vBulletin® Version 4.2.3
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
vBulletin Skin By: PurevB.com