Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 4 of 4
  1. #1
    Junior Member Dan Domski's Avatar
    Join Date
    Apr 2011
    Location
    Pittsburgh, Pennsylvania
    Posts
    4
    Member #
    27467
    [COLOR=rgb(51, 51, 51)]Like I said in the title we are getting the pop up bar asking users to install a flash plug in but there are not any flash objects on our site. I did an experiment and I found when I disable the shockwave plug-in on a machine that has it installed I get the pop-up and when I enable it on a machine that has it installed the pop-up goes away. I think I might have pin pointed the problem to a tracking script because when I remove the script the website does not ask for a plug-in. I contacted the people who made the script and they told me their script does not use flash in anyway. Does anyone have any idea why our useres are being asked to install the plug-in?[/COLOR]
    [COLOR=rgb(51, 51, 51)]
    [/COLOR]

    [COLOR=rgb(51, 51, 51)]Here is the pop-up:[/COLOR]
    [COLOR=rgb(51, 51, 51)]
    [/COLOR]
    [COLOR=rgb(51, 51, 51)][/COLOR]

  2.  

  3. #2
    Unpaid WDF Intern TheGAME1264's Avatar
    Join Date
    Dec 2002
    Location
    Not from USA
    Posts
    14,485
    Member #
    425
    Liked
    2783 times
    Is there a particular web page this behavior occurs on? I tried budgetwater.com and didn't find anything.
    If I've helped you out in any way, please pay it forward. My wife and I are walking for Autism Speaks. Please donate, and thanks.

    If someone helped you out, be sure to "Like" their post and/or help them in kind. The "Like" link is on the bottom right of each post, beside the "Share" link.

    My stuff (well, some of it): My bowling alley site | Canadian Postal Code Info (beta)

  4. #3
    Junior Member Dan Domski's Avatar
    Join Date
    Apr 2011
    Location
    Pittsburgh, Pennsylvania
    Posts
    4
    Member #
    27467
    You need to disable your shockwave plug in and you will see (depending on your browser) a message of some type appear asking you to enable the plug in or saying that the webpage was loaded with a missing plug in. It occurs on every page.

    What I have discovered since posting this is Visitstats tracking code uses a JS documents which trys to detect which version of flash the browser / end user is using. Our website does not use flash so this is not important to us.

    This is literally what we believe to be the source of the problem at this point:

    HTML Code:
    else if (window.ActiveXObject) {
            for (var i=10;i>=2;i--) {
                try {
                    var fl=eval("new ActiveXObject('ShockwaveFlash.ShockwaveFlash."+i+"');");
                    if (fl) { flaver=i; break; }
               }
               catch(e) {}
          }
        }
    The solution would be to comment it out. I am currently working with a Visistat developer to correct the problem.

  5. #4
    Unpaid WDF Intern TheGAME1264's Avatar
    Join Date
    Dec 2002
    Location
    Not from USA
    Posts
    14,485
    Member #
    425
    Liked
    2783 times
    Ahhh okay, I see what you mean.

    It definitely is doing some sort of Flash detection, but whether or not it's actually trying to run Flash, I'm not sure about.

    Now, if you just removed the Javascript without doing anything else and you don't get the error, it's the Javascript itself...which isn't surprising because a lot of third-party scripts are flaky and you really do get what you pay for. What I would do personally is move the Analytics script down where the Visistat script was (it really should be on the bottom of your page anyway) and be done with it. Multiple stats tracking scripts aren't going to tell you much, if any, more than one will.
    If I've helped you out in any way, please pay it forward. My wife and I are walking for Autism Speaks. Please donate, and thanks.

    If someone helped you out, be sure to "Like" their post and/or help them in kind. The "Like" link is on the bottom right of each post, beside the "Share" link.

    My stuff (well, some of it): My bowling alley site | Canadian Postal Code Info (beta)


Remove Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 07:19 AM.
Powered by vBulletin® Version 4.2.3
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
vBulletin Skin By: PurevB.com