Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 6 of 6

Thread: xp Web buttons

  1. #1
    Junior Member
    Join Date
    May 2005
    Location
    Devon England
    Posts
    19
    Member #
    10141
    I have just purchased a program called XP Web buttons. It creates some really nice looking buttons and menus. There is one thing that annoys me about the program. When you insert the menu onto the page, you also get a link back to the web site of XP Web buttons. If you delete the link, the rollover state stops working. I suppose you could leave the link there, it isn't visible when you preview or publish the site. Problem is, it takes up space. So in other words, if you put the menu bar in a horizontal table, this link automatically positions itself either on top of the buttons or underneath. and makes the table cell a lot higher than the actual buttons. Has anybody got any ideas how to solve this very annoying problem.

  2.  

  3. #2
    Member
    Join Date
    May 2005
    Location
    Rochester, NY
    Posts
    83
    Member #
    10054
    Can you please show us the code it writes?
    -Mike
    michael murphy
    Professional Web Development
    http://www.letsgomurphys.com/

  4. #3
    Junior Member
    Join Date
    May 2005
    Location
    Devon England
    Posts
    19
    Member #
    10141
    OK, I have just put some buttons on the page . so you can see the code.

    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
    "http://www.w3.org/TR/html4/loose.dtd">
    <html>
    <head>
    <title>Untitled Document</title>
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
    <style type="text/css">
    <!--
    .style1 {font-size: xx-small}
    -->
    </style>
    </head>

    <body>
    <table width="100%" >
    <tr bgcolor="#0000FF">
    <td colspan="2"><img src="wooding%27s_heading.jpg" width="760" height="80"></td>
    </tr>
    <tr>
    <td width="100">
    <!-- Begin XP-Web-Buttons.com -->
    <table id="xp-web-buttons.com:idfyt4o" width=0 cellpadding=0 cellspacing=0 border=0><tr><td title ="Button10">
    <a href="#" onMouseOver='xpe("8yt4oo");'onMouseOut='xpe("8yt4o n");'onMouseDown='xpe("8yt4oc");'><img src="template.html.images/bt8yt4o_0.gif" name=xpwb8yt4o width="100" height="21" border=0 alt ="Button10"></a></td></tr><tr><td title ="Button12">
    <a href="#" onMouseOver='xpe("lyt4oo");'onMouseOut='xpe("lyt4o n");'onMouseDown='xpe("lyt4oc");'><img src="template.html.images/btlyt4o_0.gif" name=xpwblyt4o width="100" height="21" border=0 alt ="Button12"></a></td></tr><tr><td title ="Button13">
    <a href="#" onMouseOver='xpe("dyt4oo");'onMouseOut='xpe("dyt4o n");'onMouseDown='xpe("dyt4oc");'><img src="template.html.images/btdyt4o_0.gif" name=xpwbdyt4o width="100" height="21" border=0 alt ="Button13"></a></td></tr><tr><td title ="Button14">
    <a href="#" onMouseOver='xpe("uyt4oo");'onMouseOut='xpe("uyt4o n");'onMouseDown='xpe("uyt4oc");'><img src="template.html.images/btuyt4o_0.gif" name=xpwbuyt4o width="100" height="21" border=0 alt ="Button14"></a></td></tr></table>
    <noscript>
    <span class="style1"><a href=http://www.xp-web-buttons.com>Created by Xp-Web-Buttons.</a></span>
    </noscript>
    <span class="style1">
    <script type="text/javascript" language="JavaScript1.1">
    <!--
    function xppr(im){var i=new Image();i.src='template.html.images/bt'+im;return i;}function xpe(id){x=id.substring(0,id.length-1);document['xpwb'+x].src=eval('xpwb'+id+'.src');if(id.indexOf('e')!=-1)document['xpwb'+x+'e'].src=eval('xpwb'+id+'e.src');}
    xpwb8yt4on=xppr('8yt4o_0.gif');xpwb8yt4oo=xppr('8y t4o_1.gif');xpwb8yt4oc=xppr('8yt4o_2.gif');xpwblyt 4on=xppr('lyt4o_0.gif');xpwblyt4oo=xppr('lyt4o_1.g if');xpwblyt4oc=xppr('lyt4o_2.gif');xpwbdyt4on=xpp r('dyt4o_0.gif');xpwbdyt4oo=xppr('dyt4o_1.gif');xp wbdyt4oc=xppr('dyt4o_2.gif');xpwbuyt4on=xppr('uyt4 o_0.gif');xpwbuyt4oo=xppr('uyt4o_1.gif');xpwbuyt4o c=xppr('uyt4o_2.gif');
    //--></script>
    </span>
    <!-- End XP-Web-Buttons.com --></td>
    <td>&nbsp;</td>
    </tr>
    <tr>
    <td>&nbsp;</td>
    <td>&nbsp;</td>
    </tr>
    </table>
    </body>
    </html>

  5. #4
    Senior Member
    Join Date
    Mar 2004
    Posts
    241
    Member #
    5465
    Try deleting this part:

    <noscript>
    <span class="style1"><a href=http://www.xp-web-buttons.com>Created by Xp-Web-Buttons.</a></span>
    </noscript>

    Alternately, in for example FrontPage, make your design, then highlight the text, when you go into Code Mode, it will highlight the code that makes that particular part. Just another way to make sure you're doing the right thing.

  6. #5
    Junior Member
    Join Date
    May 2005
    Location
    Devon England
    Posts
    19
    Member #
    10141
    Yes, that worked as far as I can tell at this moment in time, I will do some more tests. Even though I had had a good look at the code I never actually thought about the deleting it. I only deleted the text in the design view. `Obviously that wasn't enough to do the job. Anyway, thanks a lot for that.

  7. #6
    Senior Member
    Join Date
    Mar 2004
    Posts
    241
    Member #
    5465
    No prob, hope it stays for you.


Remove Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 12:50 PM.
Powered by vBulletin® Version 4.2.3
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
vBulletin Skin By: PurevB.com