Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 7 of 7
  1. #1
    Junior Member Soapmarine's Avatar
    Join Date
    Mar 2014
    Location
    Belgium
    Posts
    19
    Member #
    38686

    Permalinks in one part of site are broken after migration

    dear everybody,

    I migrated smooth working site from one domain to another, and misery started!

    Part of permalinks stopped working - they point to the Not Found Page.

    For me, it's logical if they all stopped working, but how possible that only part of them is not working? - in the Events section:http://olivia.be/events/ by clicking on Read more of the Particular Event the link points to Not found page Events | Olivia Hendrickx Research Fund

    What happened with my site? How can I find the problem?

    I'm desperate :headbang::headbang::headbang:
    Last edited by Soapmarine; Mar 11th, 2014 at 03:21 PM. Reason: I did not add links correctly

  2.  

  3. #2
    Unpaid WDF Intern TheGAME1264's Avatar
    Join Date
    Dec 2002
    Location
    Not from USA
    Posts
    14,485
    Member #
    425
    Liked
    2783 times
    What happened? Unfortunately, "could be anything" is the answer here. Corrupted or incorrect .htaccess or web.config file. Misconfigured WordPress installation. Failing plugin. It's next to impossible to figure out without access to the server in this case.
    If I've helped you out in any way, please pay it forward. My wife and I are walking for Autism Speaks. Please donate, and thanks.

    If someone helped you out, be sure to "Like" their post and/or help them in kind. The "Like" link is on the bottom right of each post, beside the "Share" link.

    My stuff (well, some of it): My bowling alley site | Canadian Postal Code Info (beta)

  4. #3
    Junior Member Soapmarine's Avatar
    Join Date
    Mar 2014
    Location
    Belgium
    Posts
    19
    Member #
    38686
    I'd eliminate already failing plugin. Everything worked on the previous domain, why should plugin start failing on a different domain?

    How can I check if .htaccess or config file are corrupted or incorrect?

  5. #4
    Unpaid WDF Intern TheGAME1264's Avatar
    Join Date
    Dec 2002
    Location
    Not from USA
    Posts
    14,485
    Member #
    425
    Liked
    2783 times
    You'd have to know what it is that you're looking for...any .htaccess settings pertaining to that event plugin, for example. I'm not sure if there are any, but I suspect there might be since other pages that I presume don't naturally exist (and thus are being served by WP) are firing okay.

    If you have a copy of the site after you took it off the old server without any changes, try to compare the two .htaccess files.

    If that doesn't do it, I'm not really sure what to suggest. The fact that some of the site works means that both the site and the server itself are working. So that means it's either going to be a flawed event plugin setting or an .htaccess rule. I'm guessing you're not on a Windows server, which is where web.config would come into play.
    If I've helped you out in any way, please pay it forward. My wife and I are walking for Autism Speaks. Please donate, and thanks.

    If someone helped you out, be sure to "Like" their post and/or help them in kind. The "Like" link is on the bottom right of each post, beside the "Share" link.

    My stuff (well, some of it): My bowling alley site | Canadian Postal Code Info (beta)

  6. #5
    Junior Member Soapmarine's Avatar
    Join Date
    Mar 2014
    Location
    Belgium
    Posts
    19
    Member #
    38686
    Quote Originally Posted by TheGAME1264 View Post
    You'd have to know what it is that you're looking for...any .htaccess settings pertaining to that event plugin, for example. I'm not sure if there are any, but I suspect there might be since other pages that I presume don't naturally exist (and thus are being served by WP) are firing okay.

    If you have a copy of the site after you took it off the old server without any changes, try to compare the two .htaccess files.
    I compared two .htaccess files and they are identical, is it normal?
    Screen Shot 2014-03-12 at 8.27.25 AM.jpg

    Quote Originally Posted by TheGAME1264 View Post
    If that doesn't do it, I'm not really sure what to suggest. The fact that some of the site works means that both the site and the server itself are working. So that means it's either going to be a flawed event plugin setting or an .htaccess rule. I'm guessing you're not on a Windows server, which is where web.config would come into play.
    I'm sorry, I dont understand what do you mean by Window server? Do you mean wp-config.php file or some setting of my hosting provider? thank you.

  7. #6
    Unpaid WDF Intern TheGAME1264's Avatar
    Join Date
    Dec 2002
    Location
    Not from USA
    Posts
    14,485
    Member #
    425
    Liked
    2783 times
    There are two major types of web host servers...Linux and Windows. Windows servers are Microsoft-based, Linux servers aren't. That's all that it means. It's the operating system of your server.

    Your problem then is pretty much localized to the plugin itself. I'd try reinstalling it. WordPress is handling your permalinks, and .htaccess isn't even involved.
    If I've helped you out in any way, please pay it forward. My wife and I are walking for Autism Speaks. Please donate, and thanks.

    If someone helped you out, be sure to "Like" their post and/or help them in kind. The "Like" link is on the bottom right of each post, beside the "Share" link.

    My stuff (well, some of it): My bowling alley site | Canadian Postal Code Info (beta)

  8. #7
    Junior Member Soapmarine's Avatar
    Join Date
    Mar 2014
    Location
    Belgium
    Posts
    19
    Member #
    38686
    I found out myself the problem, it was with WPML. Ouf!


Remove Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Tags for this Thread

All times are GMT -6. The time now is 10:46 PM.
Powered by vBulletin® Version 4.2.3
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
vBulletin Skin By: PurevB.com