Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 5 of 5

Thread: error message

  1. #1
    Junior Member
    Join Date
    May 2017
    Posts
    3
    Member #
    56650

    error message

    Hi, I'm new to the forum and a newbie in terms of website building.

    Hoping someone can help me with an error I am getting. I am using a free CMS known as webspell. I have all that installed and fine but I have tried to put an add on onto it so that I can run a shop on my website. I turned on the debug so that i could get the error message and got the following message

    Query failed:
    errorno=1146
    error=Table 'uoolo_20068227_wafc.ws_5xt_shop_config' doesn't exist
    query=SELECT * FROM ws_5xt_shop_config WHERE ID=1

    I have posted onto the webspell forum after looking for hours to find a solution but not getting an answer.

    Please please please can someone help me out with this?

  2.  

  3. #2
    Unpaid WDF Intern TheGAME1264's Avatar
    Join Date
    Dec 2002
    Location
    Not from USA
    Posts
    14,485
    Member #
    425
    Liked
    2783 times
    Your shop config table doesn't exist. Now...why it doesn't exist, I don't know. I've never used webspell before and I don't know how it works, but if it's like most CMSes it will utilize PHP and MySQL. If that's the case, download phpMyAdmin, upload it to your site, see whether that table in fact does exist, and go from there.
    If I've helped you out in any way, please pay it forward. My wife and I are walking for Autism Speaks. Please donate, and thanks.

    If someone helped you out, be sure to "Like" their post and/or help them in kind. The "Like" link is on the bottom right of each post, beside the "Share" link.

    My stuff (well, some of it): My bowling alley site | Canadian Postal Code Info (beta)

  4. #3
    Junior Member
    Join Date
    May 2017
    Posts
    3
    Member #
    56650
    the table does not exist. I added the table and it came up with a different error message.

    Query failed:
    errorno=1054
    error=Unknown column 'ID' in 'where clause'
    query=SELECT * FROM ws_5xt_shop_config WHERE ID=1

  5. #4
    Unpaid WDF Intern TheGAME1264's Avatar
    Join Date
    Dec 2002
    Location
    Not from USA
    Posts
    14,485
    Member #
    425
    Liked
    2783 times
    You'll need to add the ID field to the table.

    Now...if the table didn't exist and you had to create it, this suggests that something either wasn't installed correctly or wasn't installed at all. IF there's some sort of install folder or install.php file or something to that effect, make sure that it ran properly.
    If I've helped you out in any way, please pay it forward. My wife and I are walking for Autism Speaks. Please donate, and thanks.

    If someone helped you out, be sure to "Like" their post and/or help them in kind. The "Like" link is on the bottom right of each post, beside the "Share" link.

    My stuff (well, some of it): My bowling alley site | Canadian Postal Code Info (beta)

  6. #5
    Junior Member
    Join Date
    May 2017
    Posts
    3
    Member #
    56650
    I got it. I put he name of the table the same in the name. changed that to ID and got it all working.

    thanks for the help.


Remove Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 10:36 PM.
Powered by vBulletin® Version 4.2.3
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
vBulletin Skin By: PurevB.com