Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 4 of 4
  1. #1
    Junior Member
    Join Date
    Oct 2004
    Posts
    2
    Member #
    7820
    Hi y'all. Ive been trying to figure this out but have come up short, so I thought I would throw it out to the community.
    I am having a problem displaying some pages in netscape 6.1 browser. On some pages, where I have a background-image="somepic.jpg" in my .css file, the image displays throughout my page. While this is all well and good, I do not want the image displayed in my table making my text difficult to read, so I assigned a bgcolor="ffffff" for my table. Sometimes the page parses fine, but when I go to the secure certificate page, the bgcolor attribute does not get parsed. If I click on another page (non-secure) the problem persists. However, if I go to a 3rd page, the page displays just fine. I'm not coding anything different in the pages that get parsed correctly and the ones that dont. This only happens in netscape 6.1 (the oldest version of netscape I have loaded) but works fine in all other browsers. Has anyone else experienced this? And if so, is there a fix. I think its a netscape browser bug but have not found any document to verify this. Thanks.

  2.  

  3. #2
    Senior Member jbagley's Avatar
    Join Date
    Sep 2004
    Location
    Cape Town
    Posts
    845
    Member #
    7422
    I dont think you should worry to much about it. Not many people use netscape anymore, so the audience that will view your site with netscape I think is very small.

    I dont know much about Netscape and its rendering problems so I cant really help you with your problem. Sorry!

  4. #3
    Senior Member karinne's Avatar
    Join Date
    Dec 2003
    Location
    Aylmer QC Canada
    Posts
    1,607
    Member #
    4335
    Liked
    8 times
    Quote Originally Posted by jbagley
    I dont think you should worry to much about it. Not many people use netscape anymore, so the audience that will view your site with netscape I think is very small.

    I dont know much about Netscape and its rendering problems so I cant really help you with your problem. Sorry!
    wow... that's gotta be the worst advice ever! if you code you site properly it should work in any browser!

    ok... Big_Jim... do you have this online somewhere we can check?

    i'm not sure if this is how you actually wrote in your css but background-image="somepic.jpg" should be background-image: url("somepic.jpg");

    and you bgcolor="ffffff" should be bgcolor="#ffffff" and even then you can replace that with css by adding style="background-color: #fff;" to you table tag.

    but like i said... i link would help

    EDIT: also... one more thing you can do is put your pages throught the validator
    [a web design portfolio - Currently NOT AVAILABLE for work | web design | Re-coding | PSD-to-HTML]
    I'm also on: virb - facebook - twitter - flickr - del.icio.us

  5. #4
    Junior Member
    Join Date
    Oct 2004
    Posts
    2
    Member #
    7820
    Thanks for the quick response Karinne. I was typing fast and was at wits end about this problem. The actual bgcolor and background-image syntax is correct on my page, just not in my post. (Guess I should proofread alittle clearer before I hit submit.) The pages do validate. I have tested this in other versions of netscape and they work fine in netscape 7. This wouldn't really be an issue since it affects such a small percentage of the market but my client is running netscape 6.1 :cry:
    I'll find some space to post the code (don't want to take this live yet till I get it all hashed out). Again, thanks for the quick response.
    BJ


Remove Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 08:15 AM.
Powered by vBulletin® Version 4.2.3
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
vBulletin Skin By: PurevB.com