Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 3 of 3
  1. #1
    Junior Member Nate's Avatar
    Join Date
    Jul 2011
    Posts
    15
    Member #
    28689
    Liked
    3 times
    Hello Everyone,

    This is my second website I have created and I think it looks really good. My problem is that I designed it in IE and it does not work in any other browser. I do not understand how to get it to work in another browser because if I design it in Firefox for example then it does not display properly in IE. I am attaching a zip file and would appreciate anyone who is interested in helping me get it right. Any suggestions about my CSS or anything; I would appreciate it!

  2.  

  3. #2
    WDF Staff mlseim's Avatar
    Join Date
    Apr 2004
    Location
    Cottage Grove, Minnesota
    Posts
    7,715
    Member #
    5580
    Liked
    717 times
    Problem 1:
    You start with <html> ... no doctype defined.
    http://www.w3schools.com/tags/tag_doctype.asp
    IE has always had problems with no doc type defined.
    I'm not sure if they have fixed that with IE9, but even with HTML5
    coming soon, there is still a basic doctype defined, so you need to use it.

    Problem 2:
    No style sheet defined, except in your IE 'hacks' "if" statements" (which is always bad to use).
    You need to link to your CSS file in the head section, so all browsers can link to it.
    http://www.w3schools.com/css/css_howto.asp
    See External Style Sheet

    Problem 3:
    You're using a webpage WYSIWYG editor (like coffeecup).
    All WYSIWYG editors suck. You should code by hand, using notepad or better yet, Notepad++

    Take a peek at other peoples' HTML source code by using your browser's "View Source".
    Ronald Roe, Nate and Andrew Yurlov like this.


  4. #3
    Junior Member Nate's Avatar
    Join Date
    Jul 2011
    Posts
    15
    Member #
    28689
    Liked
    3 times
    Quote Originally Posted by mlseim, post: 228534
    Problem 1:
    You start with <html> ... no doctype defined.
    http://www.w3schools.com/tags/tag_doctype.asp
    IE has always had problems with no doc type defined.
    I'm not sure if they have fixed that with IE9, but even with HTML5
    coming soon, there is still a basic doctype defined, so you need to use it.

    Problem 2:
    No style sheet defined, except in your IE 'hacks' "if" statements" (which is always bad to use).
    You need to link to your CSS file in the head section, so all browsers can link to it.
    http://www.w3schools.com/css/css_howto.asp
    See External Style Sheet

    Problem 3:
    You're using a webpage WYSIWYG editor (like coffeecup).
    All WYSIWYG editors suck. You should code by hand, using notepad or better yet, Notepad++

    Take a peek at other peoples' HTML source code by using your browser's "View Source".
    Thank you! I will look over it tonight and let you know if I get it figured out! I appreciate you!


Remove Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 12:30 PM.
Powered by vBulletin® Version 4.2.3
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
vBulletin Skin By: PurevB.com