Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 5 of 5
  1. #1
    Junior Member
    Join Date
    Nov 2013
    Posts
    3
    Member #
    37744

    Facebook scraping my old site design

    Hopefully someone here can help! I'm no professional design (as you'll see) but I have asked this question just about everywhere and no one seems to know what the problem is:

    2 months ago I took my old web site down and replaced the homepage with a single index.html page saying the site would be back soon with a new design.
    A week ago I launched the new design and all went well.
    However, when I try to post the link on my Facebook page, Facebook converts the link to the link of an article on my old site and pulls an image from it. This link no longer exists so if people click on it, they were getting a not found error (until I rerouted the link to my homepage via my site software).
    If I go to the debug tool, it says the fetched URL is correct but the canoninical url is the one to the non existant article.
    When I click on "See exactly what our scraper sees for your URL" the HTML shown is from my old site design, that does not even exist on my server anymore! I am baffled as to where Facebook is getting this HTML code.
    My site host did move me to a new server back in April but they have chacked for me and say they find no problems. Anyone any ideas?
    You can recreate the problem by typing The People's Republic of Teesside into your status box on facebook and seeing what is actually displayed.
    Any help would be MUCH appreciated as this is driving me mad - I cannot promote my new site on my Facebook page.
    Thanks in advance for any pointers =)

  2.  

  3. #2
    WDF Staff mlseim's Avatar
    Join Date
    Apr 2004
    Location
    Cottage Grove, Minnesota
    Posts
    7,715
    Member #
    5580
    Liked
    717 times


  4. #3
    Junior Member
    Join Date
    Nov 2013
    Posts
    3
    Member #
    37744
    Thanks for taking a look but unfortunately, that's not much help.
    I am aware of all the tags/info I need in my header and as far as I'm aware, I have them all...nice opengraph tags etc.
    The problem is, Facebook isn't scraping my current page, it is somehow scraping my page from 2 months ago that doesn't even exist on my server anymore!

    When I use the Facebook debugger and view the HTML its scaping - it's completely different to that which my site has now!

    Baffling I know! Thanks for taking a look =)

  5. #4
    WDF Staff mlseim's Avatar
    Join Date
    Apr 2004
    Location
    Cottage Grove, Minnesota
    Posts
    7,715
    Member #
    5580
    Liked
    717 times
    As you can tell, I'm not a FaceBook expert ...

    Did you see this web page yet:
    Clearing Facebook Cache of a Link Preview Description & Image - Help Files Schipul - The Web Marketing Company


  6. #5
    Junior Member
    Join Date
    Nov 2013
    Posts
    3
    Member #
    37744
    Haha! Well that makes two of us =)

    That article describes what I did in my first post, which is why I'm so puzzled. After doing that, Facebook still pulls the HTML of my old site and tries to link to old pages. It's driving me nuts because if I or anyone else tries to link to my page on facebook, it just doesn't work how it should. It's like Facebook is looking at the old server that my host replaced back in April - that's the only way I can imagine that they can still see the HTML of that page!

    I really appreciate the time out you've taken to try and solve this.

    I do have another hosting package - so my next test is to transfer the site onto that hosting package - see if I still have the problem and then go from there maybe! If I don't then at least I know its a server problem!

    Thanks =)


Remove Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 01:23 PM.
Powered by vBulletin® Version 4.2.3
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
vBulletin Skin By: PurevB.com