Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 4 of 4
Like Tree1Likes
  • 1 Post By TheGAME1264

Thread: external links launch with ip address of webserver--weird

  1. #1
    Junior Member
    Join Date
    Mar 2014
    Posts
    2
    Member #
    38727

    external links launch with ip address of webserver--weird

    hello,
    Got a strange one--I self host some small websites on my own linux box running apache and this seems so simple but it's not behaving normally. I've set links before to external websites and the code all looks right such as <a href="www.externalsite.com" target="_blank">test</a> but when you save that and go back to the website and test the link it wants to lanuch it with the ip address/port of the webserver then the link --example 123.456.789:82/www.externalsite.com and it bombs with a 404 pagenot found message.
    I use no-ip.com hostnames with port redirects and virtual name servers in apache--like I said.. it's not my first rodeo and this is relly weird

  2.  

  3. #2
    Unpaid WDF Intern TheGAME1264's Avatar
    Join Date
    Dec 2002
    Location
    Not from USA
    Posts
    14,482
    Member #
    425
    Liked
    2783 times
    Add the http:// before www.externalsite.com. Otherwise, browsers are going to assume that you're referring to a relative page on your site.
    dktucson likes this.
    If I've helped you out in any way, please pay it forward. My wife and I are walking for Autism Speaks. Please donate, and thanks.

    If someone helped you out, be sure to "Like" their post and/or help them in kind. The "Like" link is on the bottom right of each post, beside the "Share" link.

    My stuff (well, some of it): My bowling alley site | Canadian Postal Code Info (beta)

  4. #3
    Junior Member
    Join Date
    Mar 2014
    Posts
    2
    Member #
    38727
    I knew it had to be something stunningly bone-headed simple--THANK YOU. This was a case of changing more than 1 thing at a time & not working--first I was trying to use just an image as a link with the http:// added and it drew a blank page.. then I tried the text and no http--got the ip address redirect--then after your helpful post I set link text with the http and added the image and bingo--away we went--thank you again

  5. #4
    Unpaid WDF Intern TheGAME1264's Avatar
    Join Date
    Dec 2002
    Location
    Not from USA
    Posts
    14,482
    Member #
    425
    Liked
    2783 times
    No worries, dude. I'm just glad it was that easy!
    If I've helped you out in any way, please pay it forward. My wife and I are walking for Autism Speaks. Please donate, and thanks.

    If someone helped you out, be sure to "Like" their post and/or help them in kind. The "Like" link is on the bottom right of each post, beside the "Share" link.

    My stuff (well, some of it): My bowling alley site | Canadian Postal Code Info (beta)


Remove Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 07:48 PM.
Powered by vBulletin® Version 4.2.3
Copyright © 2020 vBulletin Solutions, Inc. All rights reserved.
vBulletin Skin By: PurevB.com