Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 4 of 4
  1. #1
    Junior Member
    Join Date
    Dec 2016
    Posts
    2
    Member #
    55874

    Quick question about my site speed (it takes forever to load, but only sometimes)

    Hey what's up everyone!

    I made an account here, because I was unable to figure out my site speed issues on my own. Basically, it takes about 10 seconds for my site to load up, but only if I haven't been on there for a while (like a half hour or more). Sometimes, it only takes about 3 to 4 seconds for the site to load. Other times, it can take longer than 10 seconds even.

    My site is a video site, which uses Vimeo to host the videos. As of now, no single page/post contains more than just one video. The homepage has only one video on it. I'm not sure if it the videos that are resulting in the slow load speed.

    It's not my internet/wifi connection either, because I don't have this problem on other peoples' sites.

    Here are some things that I have tried so far, but these have not fixed the issue:

    - Removed Facebook "like" widget from my sidebar
    - Installed WP Super Cache (there's not many images on my site though, so this may be pointless)
    - Tried the site on several different browsers and 2 different computers, but still it's slow load sometimes and even slower load other times...never fast load.

    I use Wordpress, and I don't think that any of my HTML or CSS is too crazy or complicated (or causing some kind of loop, but then again I don't know).

    I was just wondering if anyone has any suggestions as to what may be causing the speed issues.

    Here is my site: Zombie Guitar ? Tons of Songs and Theory for Guitar

    Thanks!

  2.  

  3. #2
    Senior Member
    Join Date
    Aug 2014
    Posts
    387
    Member #
    39859
    Liked
    136 times
    It took less than 2 seconds to load for me and my computer is not that fast.

  4. #3
    Junior Member
    Join Date
    Dec 2016
    Posts
    2
    Member #
    55874
    That was a fast reply, thanks for that!

    I know...that's why it's a weird problem, this time is took 2 seconds, but sometimes it'll take over 10 seconds to load. The slow speed is inconsistent.

  5. #4
    Unpaid WDF Intern TheGAME1264's Avatar
    Join Date
    Dec 2002
    Location
    Not from USA
    Posts
    14,483
    Member #
    425
    Liked
    2783 times
    https://developers.google.com/speed/...eguitar.com%2F

    I'm not sure if you'll get the server response time warning that I did, but that's where I'd start looking. Usually server response time is indicative of at least one of two things:

    1) Scripts or applications that run slowly or are heavy (W*rdPr*ss certainly qualifies in this regard).
    2) A hosting issue; insufficient resource and/or a subpar host are the two most common "subreasons" here.

    In the case of #2, BlueHost is an EIG host. EIG is a conglomerate of hosting "brands" that are basically the hosting equivalent of Procter and Gamble, and they're horrible hosts (both personal experience and the experiences of others). Someone came up with this list a while back of all of the EIG hosting brands; it's good to keep this handy.

    http://researchasahobby.com/full-lis...panies-brands/

    Depending on what you're paying for hosting, you may not have enough resource to work with to be able to power a WP site. Some hosts are offering WP-specific hosting (including BlueHost) because of this.

    I'd start by switching your hosting plan, either away from BlueHost (YES!) or with a better plan from them (not ideal, but will help). If you do this right, you may not have to deal with #1.
    If I've helped you out in any way, please pay it forward. My wife and I are walking for Autism Speaks. Please donate, and thanks.

    If someone helped you out, be sure to "Like" their post and/or help them in kind. The "Like" link is on the bottom right of each post, beside the "Share" link.

    My stuff (well, some of it): My bowling alley site | Canadian Postal Code Info (beta)


Remove Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 11:03 AM.
Powered by vBulletin® Version 4.2.3
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
vBulletin Skin By: PurevB.com