Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 4 of 4
  1. #1
    Senior Member leprechaun13's Avatar
    Join Date
    May 2005
    Location
    Northampton
    Posts
    487
    Member #
    10058
    Please can somebody tell me why this wont HTML validate. All the erors that it gives I have fixed and uploaded but its still throwing them is it fault at W3C HTML Validator

    The site is http://customcomputerservices.co.uk/index3.php

    here is the source code
    HTML Code:
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
    <title>CCS -Custom Computer Services Northampton - Custom Built Computers, Networking and Repairs</title>
    <meta name="description" content="CCS,Custom Built Computers, Network Installation, Repairs, Upgrades, Software Installation and Home Visits "/>
     <meta name="keywords" content="CCS,Custom Computer services,checks,design,health,home,home visits,installation,networking,northampton,office,pc,repairs,spyware,systems,upgrades,virus removal,web"/>
    <META NAME="revisit-after" CONTENT="1 days"/>
    <META NAME="robots" CONTENT="FOLLOW,INDEX"/>
    <script type="text/javascript" src="js/sharemyname.js"/></script>
    <script type="text/javascript" src="js/prototype.js"></script>
    <script type="text/javascript" src="js/scriptaculous.js?load=effects"></script>
    <script type="text/javascript" src="js/lightbox.js"></script>
    <link rel="stylesheet" href="css/lightbox.css" type="text/css" media="screen" />
    <link href="css/CCS.css" rel="stylesheet" type="text/css" />
    <script type="text/javascript">
    /*<![CDATA[*/
    function sharemyname(){
    }
    /*]]>*/
    </script>
    </meta>
    </head>
    <script src="http://www.google-analytics.com/urchin.js" type="text/javascript">
    </script>
    <script type="text/javascript">
    _uacct = "UA-1191351-1";
    urchinTracker();
    </script>
    <body>
    <div class="container">
      <div class="header"></div>
       <br />
        <div class="content">
          <table width="900" height="100%" border="0" cellpadding="0">
            <tr>
              <td width="175"><div class="boxtop">Menu</div>
              <div class="lftbox">
                <p><a href="?page=home">Home</a><br />
                  <a href="?page=faq">F.A.Q</a><br />
                  <a href="?page=help">Request Help</a> <br />
                  <a href="?page=links">Links</a><br />
                  <a href="?page=webdesign">Web Design</a> <br />
                  <a href="/forums" target="_blank">Forums</a><br />
                  <a href="mailto:jay@customcomputerservices.co.uk">Contact Us</a><br />
                  <a href="http://customcomputerservices.co.uk/includes/testFile.bin">Broadband Speed Test</a><br />
                <a href="msnim:add?customcomputerservicesuk@hotmail.com">Talk To Us On MSN</a><br />
                </p>
                </div>
              <div class="boxtop">Contact Jay</div>
                <div class="lftbox">Tel: (01604) 712594<br />
              Mobile: 07753 121472<br />
              </div>            </td>
              <td height="100%"><div class="midbox">
                <div class="banner">
                  <?
       require('ledads/ad_class.php');
       echo $pla_class->adcode( );
      ?>
                </div>
                <br />
                <?php 
    $page = array_key_exists('page', $_GET) ?
    $_GET['page'] : "home" ;
    ?>
                <? include 'includes/' . $page . '.php' ; ?>
              </div></td>
              <td width="175"><div class="boxtop">New Pc's</div>
                <div class="rightbox">
                <p align="center"><img src="images/pc.png" width="134" height="87" /><br />
                  New Pcs From<br />&pound;325</p>
                </div>
                <br />
                <div class="boxtop">Networking</div>
                <div class="rightbox">
                  <p align="center"><img src="images/router.png" alt="Linksys" width="134" height="123" /><br />
                    Networks From<br />
                  &pound;65</p>
                </div></td>
            </tr>
          </table>
        </div>
    </div>
    <br />
    <br />
    <div class="copyright">Design By Philip Baucutt<br />
    Copyright &copy; 2007 Custom Computer Services </div>
    </div>
    </body>
    </html>
    Regards Phil,


  2.  

  3. #2
    Senior Member Steax's Avatar
    Join Date
    Dec 2006
    Location
    Bandung, Indonesia
    Posts
    1,207
    Member #
    14572
    It might as well have been a double post. Double topic?

    First of all, aren't all tags supposed to be in lowercase? And you have a </meta> tag, which doesn't seem to close anything.

    Oh, and... err... tables. They don't really conform for layouting... I don't know, but I've seen it common for people to make invalid pages due to using tables for layout.
    Note on code: If I give code, please note that it is simply sample code to demonstrate an effect. It is not meant to be used as-is; that is the programmer's job. I am not responsible to give you support or be held liable for anything that happens when using my code.

  4. #3
    Senior Member
    Join Date
    May 2003
    Location
    UK
    Posts
    2,354
    Member #
    1326
    1: Your doctype is XHTML 1.0 - so all code tags must be lowercase
    HTML Code:
    <META NAME="revisit-after" CONTENT="1 days"/>
    <META NAME="robots" CONTENT="FOLLOW,INDEX"/>
    2: You have a end meta tag.. which as far as I know, is not in use
    HTML Code:
    </meta>
    Try that and then see whats left.

  5. #4
    Senior Member Shani's Avatar
    Join Date
    Nov 2004
    Posts
    1,140
    Member #
    8171
    It looks like a bunch of the errors are XHTML related.

    All your tags and their contents should be in all lower case letters [minicode]<meta name="revisit-after" content="1 days" />[/minicode]

    Any special characters in javascript need to be written out so & becomes &amp;

    Make sure to end all your stand-alone tags with a slash so [minicode]<img src="hello.gif" alt="hello" /><br />[/minicode] Ah yes, and don't omit the alt.

    That will cover a good portion of the errros that are there right now. Then the real problems will be easier to spot.
    Shani

    I have an eye for detail like you'd never believe.


Remove Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 12:44 PM.
Powered by vBulletin® Version 4.2.3
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
vBulletin Skin By: PurevB.com