Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 4 of 4
  1. #1
    Member
    Join Date
    Feb 2005
    Location
    Portland, Oregon
    Posts
    93
    Member #
    8959
    view my work at
    http://www.ardia.org/efilemagic/index.html

    viewing the main nav's (layouted at top, on the blue line) in firefox is correct. for IE6, its dropped down to the next line. I couldn't figure how to keep it on the same line for IE6

    any ideas as how to resolve this?

    thanks- ardia

  2.  

  3. #2
    WDF Staff mlseim's Avatar
    Join Date
    Apr 2004
    Location
    Cottage Grove, Minnesota
    Posts
    7,716
    Member #
    5580
    Liked
    718 times
    The problem is all in here:

    ul#navmenu {
    margin: 0;
    margin-top: 19px;
    border: 0 none;
    padding: 0;
    width: 100%; /*For KHTML*/
    list-style: none;
    height: 28px;
    }

    Try this:


    ul#navmenu {
    margin: 0;
    border: 0 none;
    padding: 0;
    list-style: none;
    height: 28px;
    }


    Note the two changes. Width is no longer defined and
    the 19px top margin is eliminated.

    .


  4. #3
    Senior Member karinne's Avatar
    Join Date
    Dec 2003
    Location
    Aylmer QC Canada
    Posts
    1,607
    Member #
    4335
    Liked
    8 times
    Because the with of that ul is set to 100%

    And you have an issue with that logo in IE6 ... you omitted the width, height and alt attributes from that <img> element.
    [a web design portfolio - Currently NOT AVAILABLE for work | web design | Re-coding | PSD-to-HTML]
    I'm also on: virb - facebook - twitter - flickr - del.icio.us

  5. #4
    Member
    Join Date
    Feb 2005
    Location
    Portland, Oregon
    Posts
    93
    Member #
    8959
    wow mlseim, yes you are correct. didn't realize this would be an impact issue on IE6. thanks karinne for explaining --- so i edited that img element information.

    however it brings new problem, now that the nav menu not dropping secondary menus (after download and features section) in IE6. the joy :-(

    care to throw in why its not working now, seems a bit strange. thank you! -ardia


Remove Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 11:50 PM.
Powered by vBulletin® Version 4.2.3
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
vBulletin Skin By: PurevB.com