Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 3 of 3
  1. #1
    Junior Member
    Join Date
    Apr 2009
    Posts
    3
    Member #
    18816
    Hi all:
    I am new to this forum - thanks for having me! My question has to do with Suckerfish's drop-down menu. In IE, my submenus do not align left with the upper horizontal bar. Instead, they are indented right. I know this is an IE bug. I did everything that Patrick Griffiths and Dan Webb suggested in their "a list apart" article to counter this bug (even their example of the "pretty" drop-down menu has this alignment issue).
    This menu consists of mainly CSS so I was wondering if anyone might have any insight. If you'd like to look at my coding here is my url: http://www.kristinastevens.com/art/g...ckerfish3.html
    Thank you very much for your time! I appreciate any help you have to offer.

  2.  

  3. #2
    WDF Staff mlseim's Avatar
    Join Date
    Apr 2004
    Location
    Cottage Grove, Minnesota
    Posts
    7,720
    Member #
    5580
    Liked
    718 times
    Something looks funny in the code ... see the bold red part ...

    <ul id="nav">
    <li id="first">
    <div><a href="http://www.kristinastevens.com/">HOME</a></div>
    <ul>
    </ul>
    </li>
    <li>
    <div><a href="http://www.kristinastevens.com/web/bio.html">ABOUT US</a></div>
    <ul>
    <li><a href="http://www.kristinastevens.com/web/bio.html">BIO</a></li>
    <li><a href="http://www.kristinastevens.com/web/approach.html">APPROACH</a></li>
    </ul>
    </li>


    Is that supposed to be there?
    In fact, the whole HOME section looks wrong ...

    Check your <ul> <li> tag-starts and tag-stops ... I think you have misplaced or extra stuff.


  4. #3
    Junior Member
    Join Date
    Apr 2009
    Posts
    3
    Member #
    18816
    Thank you very much for taking the time to look into my code and point out this error. I will look into this and make the corrections. Thanks a million for your help!
    All my best,
    s_ke


Remove Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 05:12 PM.
Powered by vBulletin® Version 4.2.3
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
vBulletin Skin By: PurevB.com