Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 3 of 3
  1. #1
    Senior Member aeroweb99's Avatar
    Join Date
    Feb 2008
    Location
    Port Huron, Michigan
    Posts
    1,037
    Member #
    16468
    Liked
    1 times
    I have a very simple nav that uses a border top on a:hover but IE8 won't display it. FF, IE6 & 7, Opera, and Safari all do! I mean this is pretty bare bones! I should mention I am using IE Tester to view it, so maybe the problem lies there. If someone has IE8 could you take a look at it please?

    site link

    Here's the markup:

    Code:
    <div id="navbar">
        <div id="navbar_links">
        <a href="index.html">&nbsp;Home</a>&nbsp;&nbsp;|
        <a href="programs.html">&nbsp;Programs</a>&nbsp;&nbsp;|
        <a href="application.html">&nbsp;Application</a>&nbsp;&nbsp;|
        <a href="team.html">&nbsp;Our Team</a>&nbsp;&nbsp;|
        <a href="contact.html">&nbsp;Contact</a>  </div>  
        
      </div>
    Here's the css:

    Code:
    #navbar {
        background-color: #4ABAFF;
        background-image: url(../images/navbar_bg.png);
        background-repeat: no-repeat;
        height: 33px;
        color: #FFFFFF;
        font-size: 1.3em;
        padding-left: 15px;
        width: 943px;
    }
    
    #navbar_links {
        width: 600px;
        padding-top: 5px;
    }
    
    #navbar_links a:link {
        color: #FFFFFF;
        text-decoration: none;
    }
    
    #navbar_links a:visited {
        color: #FFFFFF;
        text-decoration: none;
    }
    
    #navbar_links a:hover {
        border-top: 2px solid #006699;
    }

  2.  

  3. #2
    Senior Member aeroweb99's Avatar
    Join Date
    Feb 2008
    Location
    Port Huron, Michigan
    Posts
    1,037
    Member #
    16468
    Liked
    1 times
    For some reason, if I add color to the hover state, it works. Go figure. I want to play around some more and find out why, if I find out, I'll post it.

  4. #3
    Senior Member aeroweb99's Avatar
    Join Date
    Feb 2008
    Location
    Port Huron, Michigan
    Posts
    1,037
    Member #
    16468
    Liked
    1 times
    Edit:::
    I did some poking around and found that ie8 does not support borders on hover. If you add it to all link states, then it works. Basically you need to set rules for ALL the "a:" states, link, visited, hover, active, in that order. set all your colors and text decoration and so on. I have not tested very many different situations but the few that I did, they were very quirky. Seems really odd to me as this seems like pretty basic stuff that even ie5 can handle.

    If someone else has some comments on this, please do. I'm getting confused about this the more I play with it!


Remove Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Search tags for this page

ie8 border not showing

,
ie8 html div border not showing
Click on a term to search for related topics.
All times are GMT -6. The time now is 09:27 PM.
Powered by vBulletin® Version 4.2.3
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
vBulletin Skin By: PurevB.com