Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 3 of 3
  1. #1
    Junior Member
    Join Date
    Oct 2009
    Location
    Perth, Australia
    Posts
    5
    Member #
    20293
    Hi!
    I'm currently trying to redesign my portfolio & I keep running into 2 problems that I cannot think of or find an explanation for.
    Please see the attached images to fully understand what I mean ...
    Firstly, there appears to be a 3 or 4 pixel difference in the placement of certain graphics in Firefox & IE, which only occurs in a vertical direction. I think it firefox that lines them all up ok, but in IE there's 4 pixels between the grey block of colour & the gradient then another 4 pixels between the gradient & the tab images. Can anyone tell me why this happens?! I've tried adjusting padding, margins, types of positioning but nothing seems to affect it.
    Secondly, (again, only in IE & not in Firefox) 2 very small lines appear at the bottom of the gaps between my navigational tabs. If I have the tabs in individual divs, it's fine. If I don't they come back, but that means adjusting all the positioning individually & Firefox doesn't line them up properly!
    Both my CSS & XHTML pass validation. I've attached my XHTML & CSS code, as well as screenshots of Firefox & IE.
    Thanks!
    Attached Images Attached Images

  2.  

  3. #2
    WDF Staff mlseim's Avatar
    Join Date
    Apr 2004
    Location
    Cottage Grove, Minnesota
    Posts
    7,693
    Member #
    5580
    Liked
    717 times
    Remove white space (unnecessary carriage returns) on all of your <a href ...></a> lines.

    <a href ...> and </a> on the same line, no carriage returns.

    Remove tabs from your HTML and other extra white spaces in the code.

    See if that makes a difference.


  4. #3
    Junior Member
    Join Date
    Oct 2009
    Location
    Perth, Australia
    Posts
    5
    Member #
    20293
    It fixed the 2 pink lines that appeared under the links, but didn't have any effect on the extra spacing that IE is adding.

    But, thank you! I had no idea that carriage returns could do such crazy things!

    Any other ideas for the crazy spacing? I can kind of work around it, but because it's happened on other websites I'm currently working on, I am curious as to what exactly is making it happen.

    Thank you for you help so far though!


Remove Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 03:35 PM.
Powered by vBulletin® Version 4.2.3
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
vBulletin Skin By: PurevB.com