Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 5 of 5
  1. #1
    Senior Member medlington's Avatar
    Join Date
    Nov 2005
    Location
    Sheffield, UK
    Posts
    377
    Member #
    11968
    Liked
    4 times
    Hi,

    Im doing a site which has a few pages in Russian.

    I know absolutly nothing about Russian and as such Im just copying and pasting the text. I've noticed that when my site is online the russian text is getting converted to gibberish like this :


    Конфиденциальноть
    Контакт
    Карта айта

    Now I dont know what it said originally but Im pretty sure this is no longer Russian

    Ive tried changing the character set but it doesnt seem to have any effect, this is my head:

    HTML Code:
    <?php session_start();?>
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head>
    <title>?????? ?? ?????????? ??????? ????: HotelStaff.com : ??????? ? ??????????? ??????? : ????????? ?? ??????? ????????? : ???????? ????? : ?????? ??? ???????.</title>
    <Meta HTTP-EQUIV="Content-Type" Content="text/html; charset=koi8-r">
    
    <META lang="RU">
    <META name="keywords" content="">
    <META NAME="DESCRIPTION" CONTENT="">
    <meta name="robots" content="index,follow">
    <link rel="stylesheet" type="text/css" href="hotelstaff_russian.css" />
    <link rel="stylesheet" type="text/css" href="top_menu.css" />
    </head>
    I have also tried:

    HTML Code:
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8"/>
    is it this line that is throwing it out:

    HTML Code:
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    if so what should I change it to?

    Also one site recomended that I set the language like this:

    HTML Code:
    <HTML lang="RU">
    Dreamweaver flags this up as an error, is there a correct way to do this?

    Thanks

  2.  

  3. #2
    WDF Staff smoseley's Avatar
    Join Date
    Mar 2003
    Location
    Boston, MA
    Posts
    9,729
    Member #
    819
    Liked
    205 times
    Russian uses the Cyrrilic character set. That's iso-8859-5

    <Meta HTTP-EQUIV="Content-Type" Content="text/html; charset=iso-8859-5">

    However, it's important to ensure that your content is actually encoded the way you specify it.

    That is, if Dreamweaver is saving the file as multibyte (utf or other) then your data will not be encoded in the charset you're specifying.

    You should check with the content source on their encoding, too.

  4. #3
    WDF Staff smoseley's Avatar
    Join Date
    Mar 2003
    Location
    Boston, MA
    Posts
    9,729
    Member #
    819
    Liked
    205 times
    The characters you posted here are UTF-8.

    I just did a test saving the file in utf-8 encoding, and with charset=utf-8 and it displayed fine.

    Here it is (attached)

  5. #4
    Senior Member medlington's Avatar
    Join Date
    Nov 2005
    Location
    Sheffield, UK
    Posts
    377
    Member #
    11968
    Liked
    4 times
    Thanks,

    it must be a setting I've got in DW, I copies and pasted the source from your file into a new file in DW and saved it, when I uploaded it it was all wrong again.

    Im going to have a look around and see if I can find it or try saving the file in a different programme.

    Im just wondering if it could be caused when I upload it? Could it being ASCII or Binary upload affect it? If I make it an HTML file and view it on my computer rather than on a server it looks fine

  6. #5
    Senior Member medlington's Avatar
    Join Date
    Nov 2005
    Location
    Sheffield, UK
    Posts
    377
    Member #
    11968
    Liked
    4 times
    hmmm,

    If I upload the file as php it gets converted to rubbish, if I upload it as .htm it works fine.

    I tried uploading it as HTML then renaming it on the server in case the ftp prog was uploading differently due to the file type but the same thing happens, if it is a php extension it doesnt work but if it is .htm it works fine.

    Could this be a server setting?


Remove Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Search tags for this page

openoffice changed text from russian to gibberish

,

russian texts showing up as gibberish

Click on a term to search for related topics.
All times are GMT -6. The time now is 12:15 PM.
Powered by vBulletin® Version 4.2.3
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
vBulletin Skin By: PurevB.com