Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 3 of 3
  1. #1
    Junior Member
    Join Date
    Mar 2011
    Posts
    9
    Member #
    27069
    Here is the situation. I am trying to position this div towards the bottom of the screen, with the table "site info" inside of it. It is working in Safari but not in Firefox. How can I get the to display properly in both browsers?

    Here is the html for the div
    [COLOR=rgb(136, 136, 136)]<div id="info_nav" class="gradient">[/COLOR]
    [COLOR=rgb(136, 136, 136)]<table>[/COLOR]
    [COLOR=rgb(136, 136, 136)] <caption>[/COLOR]
    [COLOR=rgb(136, 136, 136)] <h4>Site Info</h4>[/COLOR]
    [COLOR=rgb(136, 136, 136)] <hr />[/COLOR]
    [COLOR=rgb(136, 136, 136)] </caption>[/COLOR]
    [COLOR=rgb(136, 136, 136)] <tr>[/COLOR]
    [COLOR=rgb(136, 136, 136)] <td>[/COLOR]
    [COLOR=rgb(136, 136, 136)] <a href="site_info.php" title="Shipping Policy">Shipping Policy</a></td>[/COLOR]
    [COLOR=rgb(136, 136, 136)] <td><a href="aboutus.php">About Us</a></td>[/COLOR]
    [COLOR=rgb(136, 136, 136)] </tr>[/COLOR]
    [COLOR=rgb(136, 136, 136)] <tr>[/COLOR]
    [COLOR=rgb(136, 136, 136)] <td><a href="site_info.php">Returns</a></td>[/COLOR]
    [COLOR=rgb(136, 136, 136)] <td><a href="press.php" title="Press">Press</a></td>[/COLOR]
    [COLOR=rgb(136, 136, 136)] </tr>[/COLOR]
    [COLOR=rgb(136, 136, 136)] <tr>[/COLOR]
    [COLOR=rgb(136, 136, 136)] <td>Buying Contract</td>[/COLOR]
    [COLOR=rgb(136, 136, 136)] <td><a href="designers.php" title="Designers">Designers</a></td>[/COLOR]
    [COLOR=rgb(136, 136, 136)] </tr>[/COLOR]
    [COLOR=rgb(136, 136, 136)]</table>[/COLOR]
    [COLOR=rgb(136, 136, 136)]</div><!-- #INfo Nav -->[/COLOR]

    [COLOR=rgb(0, 0, 0)]and this is the css[/COLOR]

    [COLOR=rgb(0, 0, 0)][COLOR=rgb(153, 153, 153)]#info_nav[/COLOR]
    [COLOR=rgb(153, 153, 153)]{position:relative; [/COLOR]
    [COLOR=rgb(153, 153, 153)]top:-100px;[/COLOR]
    [COLOR=rgb(153, 153, 153)]left:600px;[/COLOR]
    [COLOR=rgb(153, 153, 153)]width:300px;[/COLOR]
    [COLOR=rgb(153, 153, 153)]}[/COLOR]
    [/COLOR]
    [COLOR=rgb(0, 0, 0)][COLOR=rgb(153, 153, 153)]#info_nav table[/COLOR]
    [COLOR=rgb(153, 153, 153)]{margin-left:auto;[/COLOR]
    [COLOR=rgb(153, 153, 153)]margin-right:auto;[/COLOR]
    [COLOR=rgb(153, 153, 153)]width:300px;[/COLOR]
    [COLOR=rgb(153, 153, 153)]}[/COLOR][/COLOR]
    [COLOR=rgb(0, 0, 0)][COLOR=rgb(153, 153, 153)]#info_nav td[/COLOR]
    [COLOR=rgb(153, 153, 153)]{margin-left:auto;[/COLOR]
    [COLOR=rgb(153, 153, 153)]margin-right:auto;[/COLOR]
    [COLOR=rgb(153, 153, 153)]}[/COLOR]

    [COLOR=rgb(153, 153, 153)][/COLOR][COLOR=rgb(153, 153, 153)][/COLOR]



    [COLOR=rgb(153, 153, 153)]#info_nav h4[/COLOR]
    [COLOR=rgb(153, 153, 153)]{font-family: Zapfino,sans-serif;[/COLOR]
    [COLOR=rgb(153, 153, 153)]font-size:12px;[/COLOR]
    [COLOR=rgb(153, 153, 153)]margin:0px;}[/COLOR][/COLOR]

    [COLOR=rgb(0, 0, 0)][COLOR=rgb(153, 153, 153)][COLOR=rgb(0, 0, 0)]In Safari it shows up as it was intended too, with the table fitting perfectly inside it's div with the id "info_nav"[/COLOR][/COLOR][/COLOR]

    [COLOR=rgb(0, 0, 0)][COLOR=rgb(153, 153, 153)][COLOR=rgb(0, 0, 0)]In Firefox the table is outside of its div.[/COLOR][/COLOR][/COLOR]


    How can I fix this so that it displays properly in both browsers?

    Here is the link
    http://www.digitalintrospect.net/lab...thenticity.php

    To CSS http://www.digitalintrospect.net/labels/css/index.css



    I would greatly appreciate any help with this.

  2.  

  3. #2
    Junior Member
    Join Date
    Mar 2011
    Posts
    9
    Member #
    27069
    Nevermind. It was because of the <hr /> tag being within the caption tag

  4. #3
    WDF Staff AlphaMare's Avatar
    Join Date
    Oct 2009
    Location
    Montreal, Canada
    Posts
    4,570
    Member #
    20277
    Liked
    878 times
    Solving your own problems often teaches more than having help (and feels heaps better too! ).

    That said, thanks for posting the solution, in case anyone has a problem with something similar it will help.

    Cheers,
    Good design should never say "Look at me!"
    It should say "Look at this." ~ David Craib


    http://digitalinsite.ca ~ my current site . . info@digitalinsite.ca ~ my email

    If you feel that someone's post helped you fix your problem, answered your question, or just made you feel better, feel free to "Like" their post. The "Like" link is at the bottom right of each post, along side the "reply" link. And if you are being helped here, try to help someone else - pass it on!


Remove Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 05:58 AM.
Powered by vBulletin® Version 4.2.3
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
vBulletin Skin By: PurevB.com