Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 7 of 7
  1. #1
    Junior Member
    Join Date
    Apr 2011
    Posts
    4
    Member #
    27333
    Hi, Im a web designer from the South Coast of Western Australia, I'm wondering if any one can help me with a problem Im having, on this page http://terroirandtable.com.au/gallery.html I have drop down menus on the About, News and Services menu items but for some reason the Services drop down is not working. Can anyone see where Im going wrong, thanks.

  2.  

  3. #2
    WDF Staff AlphaMare's Avatar
    Join Date
    Oct 2009
    Location
    Montreal, Canada
    Posts
    4,570
    Member #
    20277
    Liked
    878 times
    HI - I see that you are using Dreamweaver. It has some bad habits that I know of - for example it bloats out the code terribly if you use the design view.

    It also tends to forget to remove related bits of code from elsewhere on the page if you delete and re-insert something that requires a javascript to run - perhaps this is what happened with that part of the drop-down?

    Apparently the problem only exists on the Gallery page and not the Home page - I would suspect that you have some conflicting javascript going on somewhere. I tried looking at the code to see where the problem lies but it is so kludgy right now that I can't find it.

    I would like to see you put your styles into a separate CSS file and your functions and javascripts into separate files as well, and comment them as much as you can. That could help you to pinpoint the problem. Right now you have one javascript file called mm_menu.js that seems to be necessary to control the menu, but you also have a lot of other javascript right in the page that I can't figure out.

    Maybe someone else here who is better at that than I am can help you more.
    Good design should never say "Look at me!"
    It should say "Look at this." ~ David Craib


    http://digitalinsite.ca ~ my current site . . info@digitalinsite.ca ~ my email

    If you feel that someone's post helped you fix your problem, answered your question, or just made you feel better, feel free to "Like" their post. The "Like" link is at the bottom right of each post, along side the "reply" link. And if you are being helped here, try to help someone else - pass it on!

  4. #3
    Junior Member
    Join Date
    Apr 2011
    Posts
    4
    Member #
    27333
    Thanks AlphaMare, I ended up thinking around the problem, maybe not as neat as it could be but its working, thanks again for your help.

  5. #4
    WDF Staff AlphaMare's Avatar
    Join Date
    Oct 2009
    Location
    Montreal, Canada
    Posts
    4,570
    Member #
    20277
    Liked
    878 times
    Cool, glad you got it working. Can you tell us how? It may help someone else down the line...
    Good design should never say "Look at me!"
    It should say "Look at this." ~ David Craib


    http://digitalinsite.ca ~ my current site . . info@digitalinsite.ca ~ my email

    If you feel that someone's post helped you fix your problem, answered your question, or just made you feel better, feel free to "Like" their post. The "Like" link is at the bottom right of each post, along side the "reply" link. And if you are being helped here, try to help someone else - pass it on!

  6. #5
    Junior Member
    Join Date
    Apr 2011
    Posts
    4
    Member #
    27333
    I cheated, copied the gallery and pasted on another page that already had that new drop down working.

  7. #6
    WDF Staff AlphaMare's Avatar
    Join Date
    Oct 2009
    Location
    Montreal, Canada
    Posts
    4,570
    Member #
    20277
    Liked
    878 times
    Basically, you just used your working page as a template - nothing wrong with that!
    Good design should never say "Look at me!"
    It should say "Look at this." ~ David Craib


    http://digitalinsite.ca ~ my current site . . info@digitalinsite.ca ~ my email

    If you feel that someone's post helped you fix your problem, answered your question, or just made you feel better, feel free to "Like" their post. The "Like" link is at the bottom right of each post, along side the "reply" link. And if you are being helped here, try to help someone else - pass it on!

  8. #7
    Junior Member
    Join Date
    Apr 2011
    Posts
    4
    Member #
    27333
    Thanks


Remove Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 06:02 PM.
Powered by vBulletin® Version 4.2.3
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
vBulletin Skin By: PurevB.com