Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 6 of 6
  1. #1
    Senior Member kralcx's Avatar
    Join Date
    Jan 2010
    Location
    3rd Planet from the Sun
    Posts
    140
    Member #
    20799
    Liked
    18 times
    I'm hoping someone can help me with this; I'm hoping it is something simple that I am overlooking.

    My design looks perfect when tested in my browser (IE,FF, Opera, Chrome, Safari), however when I upload it to my server I loose my button image. The hotspot is still there but the button image is gone. (By the way it is a CSS rollover button). The button should be red with white text located below the picture of the woman under the text "Get Herbal Fiberblend Now"

    Here is a snippet of the CSS:

    #button {
    margin-left: 118px;
    margin-top: 9px;
    display: block;
    float: left;
    height: 31px;
    margin-bottom: 0;
    width: 208px;
    background: url(images/button.gif) no-repeat 0 0;
    }

    #button:hover
    {
    background-position: 0 -31px;
    }

    and a snippet of the html code:

    <a href="http://www.theaimcompanies.com/produ...amp;aimstore=y" id="button" title="Try Herbal Fiberblend Today!" /><span></span></a>
    <div class="clearFloat"></div>

    the webpage is: www.hiygin.com/herbalfiberblend/herbalfiberblend.html

    I checked the code and the images; I uploaded it to my server the same files that I tested on my home computer. Any help is greatly appreciated. If you need any more information just let me know. Thanks in advance.

  2.  

  3. #2
    Senior Member kralcx's Avatar
    Join Date
    Jan 2010
    Location
    3rd Planet from the Sun
    Posts
    140
    Member #
    20799
    Liked
    18 times
    I just did something stupid somehow my computer crashed and I lost my css file. I spent so much time on this its going to take me a while to put it back together

  4. #3
    Senior Member Ronald Roe's Avatar
    Join Date
    Mar 2011
    Location
    Oklahoma City
    Posts
    3,141
    Member #
    27197
    Liked
    959 times
    Usually, this has to do with the path. Try using an absolute path and see if that helps. As far as losing everything, didn't you upload it to a server? Just download it from there...
    Ron Roe
    Web Developer
    "If every app were designed using the same design template, oh wait...Bootstrap."

  5. #4
    Senior Member kralcx's Avatar
    Join Date
    Jan 2010
    Location
    3rd Planet from the Sun
    Posts
    140
    Member #
    20799
    Liked
    18 times
    Okay I got my CSS code back up ....(I got to remember backup, backup, backup, backup)

    anyhow I figured out what the problem was...

    my original code was: background: url(images/button.gif) no-repeat 0 0;

    the correct working code is: background: url(images/Button.gif) no-repeat 0 0;

    I didn't realize capitalization was so important! Is this some sort of rule I just didn't know about, or was my issue some kind of fluke?

    Any comments much appreciated?

  6. #5
    Unpaid WDF Intern TheGAME1264's Avatar
    Join Date
    Dec 2002
    Location
    Not from USA
    Posts
    14,485
    Member #
    425
    Liked
    2783 times
    Not a fluke at all. Some servers are CaSe-SeNsItIvE. So you're always better off naming files in lowercase and referring to them that way.
    If I've helped you out in any way, please pay it forward. My wife and I are walking for Autism Speaks. Please donate, and thanks.

    If someone helped you out, be sure to "Like" their post and/or help them in kind. The "Like" link is on the bottom right of each post, beside the "Share" link.

    My stuff (well, some of it): My bowling alley site | Canadian Postal Code Info (beta)

  7. #6
    Senior Member kralcx's Avatar
    Join Date
    Jan 2010
    Location
    3rd Planet from the Sun
    Posts
    140
    Member #
    20799
    Liked
    18 times
    Okay thank you for that. I will remember that from now on.


Remove Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 05:44 AM.
Powered by vBulletin® Version 4.2.3
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
vBulletin Skin By: PurevB.com