Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 8 of 8
  1. #1
    Senior Member
    Join Date
    Jun 2003
    Location
    Australia
    Posts
    735
    Member #
    1935
    the latest site thta i created uses the background-image: url(); CSS property but when i tested in Opera, Netscape and Mozilla it didnt work!

    Is IE the only browser that supports background-image?? Because i have used it b4 with no problems but im not sure whether i tested it in other browsers.

    thanks

  2.  

  3. #2
    Senior Member filburt1's Avatar
    Join Date
    Jul 2002
    Location
    Maryland, US
    Posts
    11,774
    Member #
    3
    Liked
    21 times
    Code:
    <span style="width:50px; height:50px; background-image:url('path/to/image.gif')">text</span>
    Works fine in Moz and IE.
    filburt1, Web Design Forums.net founder
    Site of the Month contest: submit your site or vote for the winner!

  4. #3
    Senior Member
    Join Date
    Jun 2003
    Location
    Australia
    Posts
    735
    Member #
    1935
    u forgot the url();
    or does it work that way aswell?

  5. #4
    Senior Member filburt1's Avatar
    Join Date
    Jul 2002
    Location
    Maryland, US
    Posts
    11,774
    Member #
    3
    Liked
    21 times
    No, I just forgot it

    What's the exact code you're using? Also, remember if you're using a separate CSS file, the image locations are relative to the CSS file's path, not the including HTML's path.
    filburt1, Web Design Forums.net founder
    Site of the Month contest: submit your site or vote for the winner!

  6. #5
    Senior Member
    Join Date
    Jun 2003
    Location
    Australia
    Posts
    735
    Member #
    1935
    oh sorry. I fixed the error.
    I was being dumb and used backslash instead of forwardslash.

    thanks for waking me up

  7. #6
    Senior Member Brak's Avatar
    Join Date
    Apr 2003
    Location
    San Francisco, CA
    Posts
    3,413
    Member #
    1217
    Liked
    2 times
    I have a question along the same lines... Does IE 5.2 for mac NOT support this? I have the CSS used on http://www.neathdesign.com/styles.css and when you look at any of my pages, the body background doesn't show up on that combination. Every other combination works fine from what I've tested. Anyone have any light to this? =x Do you think I need to add a y-repeat in there? I havne't tried that yet...
    Kyle Neath: Rockstar extraordinare
    The blog | The poetry site | The Spore site

  8. #7
    Senior Member Brak's Avatar
    Join Date
    Apr 2003
    Location
    San Francisco, CA
    Posts
    3,413
    Member #
    1217
    Liked
    2 times
    PS I'm talking about mainbody class.
    Kyle Neath: Rockstar extraordinare
    The blog | The poetry site | The Spore site

  9. #8
    Senior Member
    Join Date
    Jun 2003
    Location
    Australia
    Posts
    735
    Member #
    1935
    i havent had much experience with mac IE but just in case you forgot you have to tell it to repeat it think
    background-repeat: repeat;

    i cant see why IE 5.2 wouldnt support it. Every other browser does.


Remove Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 05:45 PM.
Powered by vBulletin® Version 4.2.3
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
vBulletin Skin By: PurevB.com