Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
  1. #1
    Junior Member
    Join Date
    Aug 2014
    Posts
    11
    Member #
    39937

    Need help with setting up a link

    Hi Guys,

    I very new with this stuff and am trying to create a personal website. I have been stuck for countless hours now. I was hoping somebody can help me out. I downloaded a template online and am using dreamweaver to edit it. The problem is in the pasted code below

    <!-- Begin Navigation -->
    <div id="navigation">
    <ul>
    <li><a href="http://google.com" title="Home">Home</a></li>

    <li><a href="#" title="Services">Services</a></li>
    <li><a href="#" title="About Us">About Us</a></li>
    <li><a href="#" title="Gallery">Gallery</a></li>
    <li><a href="#" title="Contact Us">Contact Us</a></li>
    </ul>
    <div class="cl">&nbsp;</div>
    </div>
    <!-- End Navigation -->


    The problem i am having is this. Whenever I am testing the site, clicking on the home icon does nothing. I can never get it to redirect me to a link of my choice ( in this case google.com). The only way that I am able to be redirected is if I delete the line <ul> . I am then able to be redirected to a link by clicking on the home button. However, deleting <ul> stops other features from working with the navigation bar. Any help would be appreciated. I cannot move forward until i get this down.

    Thanks in advance.

  2.  

  3. #2
    Senior Member Vapr_Arts's Avatar
    Join Date
    Oct 2013
    Location
    California
    Posts
    1,930
    Member #
    37412
    Liked
    544 times
    Because you are testing it inside of dreamweaver and not an actual browser. Dreamweaver is a horrible program when it comes to anything other being just a text editor. Test it inside your browser and it should work


    Regretfully sent from my iPhone using Tapatalk during lunch and other breaks

  4. #3
    Junior Member
    Join Date
    Aug 2014
    Posts
    11
    Member #
    39937
    Quote Originally Posted by Vapr_Arts View Post
    Because you are testing it inside of dreamweaver and not an actual browser. Dreamweaver is a horrible program when it comes to anything other being just a text editor. Test it inside your browser and it should work


    Regretfully sent from my iPhone using Tapatalk during lunch and other breaks


    Thanks for the response, but I do test it without Dreamweaver. I open the home.html file and try it out, but don't get redirected.

  5. #4
    Senior Member Vapr_Arts's Avatar
    Join Date
    Oct 2013
    Location
    California
    Posts
    1,930
    Member #
    37412
    Liked
    544 times

    Need help with setting up a link

    From what i can tell it should open up google when you use the code you provided. It will be different for linking to a separate file and not a url.

    First home pages are typically called "index.html

    Thats not going to fix your problem, just a heads up on that..

    Second, you have to have it structured correctly. Put into the right folders and when you list the file you want to open you must do so in a way that the browser knows where the file is.

    For example: if all your pages are in the same folder you should just be able to call the file normally like "index.html"
    If its found inside a separate folder you have to specify where exactly to look. You can do it by entering "theFolderName/index.html"

    I can only help you out with what to type if i know how ur site is structured inside of the folders. Is this only on your computer or do you have it hosted anywhere?


    Regretfully sent from my iPhone using Tapatalk during lunch and other breaks
    Last edited by Vapr_Arts; Aug 20th, 2014 at 03:53 PM.

  6. #5
    Junior Member
    Join Date
    Aug 2014
    Posts
    11
    Member #
    39937
    Quote Originally Posted by Vapr_Arts View Post
    From what i can tell it should open up google when you use the code you provided. It will be different for linking to a separate file and not a url.

    First home pages are typically called "index.html

    Thats not going to fix your problem, just a heads up on that..

    Second, you have to have it structured correctly. Put into the right folders and when you list the file you want to open you must do so in a way that the browser knows where the file is.

    For example: if all your pages are in the same folder you should just be able to call the file normally like "index.html"
    If its found inside a separate folder you have to specify where exactly to look. You can do it by entering "theFolderName/index.html"

    I can only help you out with what to type if i know how ur site is structured inside of the folders. Is this only on your computer or do you have it hosted anywhere?


    Regretfully sent from my iPhone using Tapatalk during lunch and other breaks

    Thanks again, I tried moving my files into the same folder as the index.html (home.html in this case) but still nothing. I would appreciate it if you could take a look for me. I uploaded it to this site

    http://www.filedropper.com/websitehelp

    just the security code has to be all caps when you copy it. I am so stuck right now. I would appreciate any other help. I would understand if you do not want to download it.

    Thanks,

  7. #6
    Banned
    Join Date
    Jun 2014
    Location
    Laredo, Texas
    Posts
    16
    Member #
    39482
    Richard,

    Please make sure that you are online. I tested the code in adobe edge code cc and it worked fine.

    Also, please remove the "title" attribute. It is not a valid <a> attribute. Please see below.

    HTML a tag

  8. #7
    Unpaid WDF Intern TheGAME1264's Avatar
    Join Date
    Dec 2002
    Location
    Not from USA
    Posts
    14,483
    Member #
    425
    Liked
    2783 times
    Ummmm....yes it is.

    HTML Global attributes
    If I've helped you out in any way, please pay it forward. My wife and I are walking for Autism Speaks. Please donate, and thanks.

    If someone helped you out, be sure to "Like" their post and/or help them in kind. The "Like" link is on the bottom right of each post, beside the "Share" link.

    My stuff (well, some of it): My bowling alley site | Canadian Postal Code Info (beta)

  9. #8
    Banned
    Join Date
    Jun 2014
    Location
    Laredo, Texas
    Posts
    16
    Member #
    39482
    Thanks. I have never used the " title " attribute in <a>. I have used it and am familiar with it in <img>.

    Thanks again. I learned something new.

    Quote Originally Posted by TheGAME1264 View Post
    Ummmm....yes it is.

    HTML Global attributes

  10. #9
    Senior Member Vapr_Arts's Avatar
    Join Date
    Oct 2013
    Location
    California
    Posts
    1,930
    Member #
    37412
    Liked
    544 times
    The only reason it wouldn't be working is if you dont have it pointing in the right location to find the page you want it to go to.

    You showed us with google which should work how you have it. It will not be the same as finding the page you want tho. Show us the code you have with the file u want and not to google.

    I will not download the file. Sorry but 90% of the time I'm on here i am on my phone. No where near my computer. Maybe someone else will?


    Regretfully sent from my iPhone using Tapatalk during lunch and other breaks

  11. #10
    Junior Member
    Join Date
    Aug 2014
    Posts
    11
    Member #
    39937
    Quote Originally Posted by Vapr_Arts View Post
    The only reason it wouldn't be working is if you dont have it pointing in the right location to find the page you want it to go to.

    You showed us with google which should work how you have it. It will not be the same as finding the page you want tho. Show us the code you have with the file u want and not to google.

    I will not download the file. Sorry but 90% of the time I'm on here i am on my phone. No where near my computer. Maybe someone else will?


    Regretfully sent from my iPhone using Tapatalk during lunch and other breaks


    Thank you all of you. Let me actually try to upload it to a website and see if it works. Thanks for all the support. I will let you know how it goes.


Page 1 of 2 1 2 LastLast

Remove Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Tags for this Thread

All times are GMT -6. The time now is 12:10 AM.
Powered by vBulletin® Version 4.2.3
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
vBulletin Skin By: PurevB.com