Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 3 of 3
  1. #1
    Junior Member patrick66's Avatar
    Join Date
    May 2003
    Posts
    11
    Member #
    1421
    Hi,

    I recently installed an iframe onto my site (www.goldrushsims.tk) and it works fine. However, when I visit a page that requires cookies, like a forum, the cookies are not applied. Usually, when I visit the forums, I am automatically logged in, but when inside an iframe, the cookies seem to be lost. Can anyone tell me how to get around this problem?

    Thank you!

  2.  

  3. #2
    Junior Member
    Join Date
    Sep 2003
    Posts
    3
    Member #
    3192
    unfortunately there isnt anyway to truly get around this problem. since the page is being loaded in an iframe, it uses the parent window as the cookie source. This means when the inner page looks for a cookie, IE goes and checks for cookies from the domain of the parent window (not the inner window) and of course doesnt find anything.

    If you need cookie support you really shouldnt be using iframes.

  4. #3
    Junior Member Fusion's Avatar
    Join Date
    Sep 2003
    Location
    Posts
    5
    Member #
    3238
    Why oh why are you using an iFrame?? You are going to make me cry.....


Remove Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 01:27 AM.
Powered by vBulletin® Version 4.2.3
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
vBulletin Skin By: PurevB.com