Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 6 of 6
Like Tree1Likes
  • 1 Post By TheGAME1264

Thread: hyperlink doesn't work

  1. #1
    Junior Member
    Join Date
    Sep 2017
    Posts
    4
    Member #
    57423

    hyperlink doesn't work

    Hello,

    I'm new here. My name is David, I live in the Netherlands and am new to webdesign and this forum.
    I have a problem with a very basic HTML code that's drives me crazy. Maybe someone here can help me out.

    <!doctype html>
    <html>
    <head>
    <meta charset=“utf-8”>
    <title>Hyperlink</title>
    </head>
    <body>Click <a href=“test.htm”>on this link</a>
    to go to another page.
    </body>
    </html>

    The name of the other page is test.htm and is in the same folder.
    The problem is, when I click on the link, the browser doesn't find the file.
    But when I remove the quote marks ... <a href=test.htm>on this link</a>. ... the file is found.
    How come ?
    I have a macbook and try to do this with the texteditor. Before I save the code I make sure the code format is in plain text.

  2.  

  3. #2
    Unpaid WDF Intern TheGAME1264's Avatar
    Join Date
    Dec 2002
    Location
    Not from USA
    Posts
    14,485
    Member #
    425
    Liked
    2783 times
    Are you sure you used the same quote marks on both sides? I've seen things like that happen with those funky angled quotes before. If that doesn't work, try single quotes (') and see if they do.
    m3n0tu18 likes this.
    If I've helped you out in any way, please pay it forward. My wife and I are walking for Autism Speaks. Please donate, and thanks.

    If someone helped you out, be sure to "Like" their post and/or help them in kind. The "Like" link is on the bottom right of each post, beside the "Share" link.

    My stuff (well, some of it): My bowling alley site | Canadian Postal Code Info (beta)

  4. #3
    Senior Member
    Join Date
    Feb 2006
    Posts
    800
    Member #
    12463
    Liked
    296 times
    Use an actual code editor and eliminate the curly quotes.

    https://www.google.com/search?q=free...utf-8&oe=utf-8
    Last edited by delstu; Sep 19th, 2017 at 06:59 PM.

  5. #4
    Junior Member
    Join Date
    Sep 2017
    Posts
    4
    Member #
    57423
    thank you for your replies.

  6. #5
    Junior Member
    Join Date
    Sep 2017
    Posts
    4
    Member #
    57423
    Quote Originally Posted by delstu View Post
    Use an actual code editor and eliminate the curly quotes.

    https://www.google.com/search?q=free...utf-8&oe=utf-8
    I want to you use textedit because in the course i learning from they use it.
    but thanks anyway.

  7. #6
    Junior Member
    Join Date
    Sep 2017
    Posts
    4
    Member #
    57423
    Quote Originally Posted by TheGAME1264 View Post
    Are you sure you used the same quote marks on both sides? I've seen things like that happen with those funky angled quotes before. If that doesn't work, try single quotes (') and see if they do.

    I finally know what the problem was. when i read about those funky angled quotes I started to search for a way to get rid of them.
    In the preferences of textedit there are three selections made.



    Smart quotes
    Smart dashes
    smart links

    I deselected them and the funky angled quotes were gone.
    After saving the htm file... the link worked like it was supposed to work.

    thanks again. ....... and sorry for my bad English


Remove Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 04:33 PM.
Powered by vBulletin® Version 4.2.3
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
vBulletin Skin By: PurevB.com