Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 1 of 1
  1. #1
    Junior Member Vanilla-Gorilla's Avatar
    Join Date
    Oct 2020
    Posts
    1
    Member #
    62060

    Picture element, WebP and PageSpeed Insights

    Hello,

    I recently launched a new website, vanillagorillahosting.com. It scores 100/100 on PageSpeed Insights but PSI gives me the suggestion to use next-gen image formats. And I would love to! My very optimized banner is about 200k in jpg but about 75k in webp. However, Safari doesnít support webp. It is starting to support webp with the new Safari 14 (Sept 2020) BUT it seems thatís only if itís Safari 14 used on the new OS/iOS, Big Sur. Since Big Sur does not support my iMac (and I believe adoption will be too low for the time being) I canít rely on Safariís webp support.

    So, I turn to CSS and the <picture> element. Great, a jpg banner for Safari and a webp banner for everyone else. Awesome, it works! Except suddenly my PSI score drops and my Cumulative Layout Shift goes way up. Not good.

    I really want to use webp images but canít have a big white box appear for Safari users. And I donít want to compromise my PSI score. Does anyone have a suggestion on how to solve this issue? Thanks for your help!

  2.  


Remove Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 10:54 PM.
Powered by vBulletin® Version 4.2.3
Copyright © 2020 vBulletin Solutions, Inc. All rights reserved.
vBulletin Skin By: PurevB.com