Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
  1. #1
    thw
    thw is offline
    Junior Member
    Join Date
    Apr 2004
    Posts
    16
    Member #
    5809
    Hello everyone... I have some trouble making a background colour set in a CSS file to show up in Opera.

    Here's the site:
    http://www.route414.com

    The coding is:
    Code:
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head>
    <title>Route 414 - black & white photography</title>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
    <link href="styles.css" rel="stylesheet" type="text/css" />
    </head>
    
    <body>
    <p class="title"><a href="main.htm"><img src="images/logo.gif" width="210" height="55" border="0" /></a></p>
    <p class="title"><a href="main.htm"><img src="photos/08.jpg" width="450" height="300" border="0" /></a></p>
    <p>&nbsp;</p>
    <p><img src="images/copyright.gif" width="125" height="9" /></p>
    </body>
    </html>
    And the CSS stylesheet like so:
    Code:
    body {
    	font-family: "Century Gothic", "Helvetica", "Arial";
    	background-color: #98AAB5;
    	scrollbar-face-color: #98AAB5;
    	scrollbar-highlight-color: #98AAB5;
    	scrollbar-3dlight-color: #98AAB5;
    	scrollbar-darkshadow-color: #98AAB5;
    	scrollbar-shadow-color: #98AAB5;
    	scrollbar-arrow-color: #FFFFFF;
    	scrollbar-track-color: #98AAB5;
    	font-weight: bolder;
    	}
    a {
    	color: #98AAB5;
    	text-decoration: underline;
    	background-color: #FFFFFF;
    	}
    .main {
    	font-size: .9em;
    	font-style: normal;
    	line-height: normal;
    	font-variant: normal;
    	color: #98AAB5;
    	background-color: #FFFFFF;
    }
    ul {
    	font-size: 0.9em;
    	color: #98AAB5;
    	list-style-type: circle;
    	}
    .title {
    	text-align: center;
    }
    The page shows up correctly in IE, Navigator, Firefox but not Opera. Is there something wrong with my codes?

  2.  

  3. #2
    Senior Member Brak's Avatar
    Join Date
    Apr 2003
    Location
    San Francisco, CA
    Posts
    3,413
    Member #
    1217
    Liked
    2 times
    try changing background-color to the shorthand property background:
    Kyle Neath: Rockstar extraordinare
    The blog | The poetry site | The Spore site

  4. #3
    Senior Member filburt1's Avatar
    Join Date
    Jul 2002
    Location
    Maryland, US
    Posts
    11,774
    Member #
    3
    Liked
    21 times
    You can also try changing "body" to "body, html."
    filburt1, Web Design Forums.net founder
    Site of the Month contest: submit your site or vote for the winner!

  5. #4
    Senior Member
    Join Date
    Dec 2003
    Posts
    1,274
    Member #
    4362
    Create a 1x1 image with that color and put it as background image.
    Code:
    body {
    	font-family: "Century Gothic", "Helvetica", "Arial";
    	background-color: #98AAB5;
            background-image:url(bg.png);
    	scrollbar-face-color: #98AAB5;
    	scrollbar-highlight-color: #98AAB5;
    	scrollbar-3dlight-color: #98AAB5;
    	scrollbar-darkshadow-color: #98AAB5;
    	scrollbar-shadow-color: #98AAB5;
    	scrollbar-arrow-color: #FFFFFF;
    	scrollbar-track-color: #98AAB5;
    	font-weight: bolder;
    	}

  6. #5
    Senior Member karinne's Avatar
    Join Date
    Dec 2003
    Location
    Aylmer QC Canada
    Posts
    1,607
    Member #
    4335
    Liked
    8 times
    remove the "" around Helverica and Arial in your font-family. you don't need to wrap font names in "" only when there's a space in the name... so keep 'em on "Century Gothic".

    don't know what's going on but i got it working www.karinne.net/route414.html

    hth
    [a web design portfolio - Currently NOT AVAILABLE for work | web design | Re-coding | PSD-to-HTML]
    I'm also on: virb - facebook - twitter - flickr - del.icio.us

  7. #6
    Senior Member
    Join Date
    Dec 2003
    Posts
    1,274
    Member #
    4362
    Yeah, it works there. What have you changed?

  8. #7
    Senior Member karinne's Avatar
    Join Date
    Dec 2003
    Location
    Aylmer QC Canada
    Posts
    1,607
    Member #
    4335
    Liked
    8 times
    ^ me? i removed the "" in the font-family like i said
    [a web design portfolio - Currently NOT AVAILABLE for work | web design | Re-coding | PSD-to-HTML]
    I'm also on: virb - facebook - twitter - flickr - del.icio.us

  9. #8
    Senior Member
    Join Date
    Dec 2003
    Posts
    1,274
    Member #
    4362
    Only that? Stupid fix...

  10. #9
    thw
    thw is offline
    Junior Member
    Join Date
    Apr 2004
    Posts
    16
    Member #
    5809
    Thanks all... I'll keep working then!

  11. #10
    thw
    thw is offline
    Junior Member
    Join Date
    Apr 2004
    Posts
    16
    Member #
    5809
    Quote Originally Posted by Brak
    try changing background-color to the shorthand property background:
    What's shorthand property background?


Page 1 of 2 1 2 LastLast

Remove Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 06:50 PM.
Powered by vBulletin® Version 4.2.3
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
vBulletin Skin By: PurevB.com