Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 6 of 6
  1. #1
    Junior Member
    Join Date
    May 2003
    Posts
    9
    Member #
    1406
    I've been building a site which is basically contained in one page, and have been having a hell of a time trying to make my multi-layered dynamic scrollers work. I've made it work with multiple layers of content in one scrolling window, and I've done it with multiple scrolling windows. But for some reason, I can't seem to get both to work together (multiple layers of content in multiple scrolling windows).

    I'm going to have a permanent imprint of my keyboard in my head if I don't get this soon.

    Here's the page I'm working on:
    http://www.yukonharley-davidson.com/...torclothes.php

    I figure the problem is in here:
    http://www.yukonharley-davidson.com/...ts/scroller.js

    ...and here's a working version (although it's only a single content window):
    http://www.arcticweb.ca/

    I'm not getting any errors, and the code seems to be executing, just not working. If anyone could point me in the right direction I'd be eternally grateful!

    Thanks guys

  2.  

  3. #2
    WDF Staff smoseley's Avatar
    Join Date
    Mar 2003
    Location
    Boston, MA
    Posts
    9,729
    Member #
    819
    Liked
    205 times
    LOL... how funny, I just did something like this for one of our members. I resolved it by only having one scrolling div and loading the content from other divs into that one when a link is clicked. Here's the link:

    http://www.webdesignforums.net/thread6782.html

  4. #3
    Junior Member
    Join Date
    May 2003
    Posts
    9
    Member #
    1406
    Thanks for the tip. I like how that works...although I'm having some problems with Netscape compatibility. IE's lookin good.

    NS 4.7 (mac) doesn't display changes at all. NS 7 (pc) is looking pretty messed up. The page is exploding. Seems that the layers, although invisible, are pushing the table apart. Any idea how to fix this?

    Here's the site:
    http://www.yukonharley-davidson.com/...torclothes.php

    (only products listed under Men's T's so far)

  5. #4
    WDF Staff smoseley's Avatar
    Join Date
    Mar 2003
    Location
    Boston, MA
    Posts
    9,729
    Member #
    819
    Liked
    205 times
    I haven't checked compatibility of that script. You might want to try either putting the layers at the end of your script or setting style="display:none" to fix the spacing issues. I think if yo uset display to none, though, Netscape won't be able to read the content out of them.

  6. #5
    Junior Member
    Join Date
    May 2003
    Posts
    9
    Member #
    1406
    If I take the layers out of my script and put them at the end, then I'm can't use relative positioning. That means a lot more calculations for me to find out where to place the things. I'd really rather not get into that.

    The replacing of layer content doesn't seem to work in NS4.x either, which is kind of annoying. I hate making sites that are browser specific...but what the hell can I do? Who has an extra 6 months of time to devote to browser quirks and compatibility issues on every damn site?

    Any ideas on how to make these layers visible in NS4.x (when I swap the content)...or how to hold the page together in NS7?

    The site is pretty much live now, so if I can't get it working in NS fairly easily, then @#%! it.

    http://www.yukonharley-davidson.com/

  7. #6
    Junior Member
    Join Date
    May 2003
    Posts
    9
    Member #
    1406
    I see what you mean now about putting the layers at the end of the page now. Unfortunately, that only keeps the page together until someone selects one of the longer content listings.

    This must have something to do with the overflow:hidden / clip: rect(x x x x) not applying from the layers containing the scrolling content. It seems to work when the scrolled content is up, but not down for some reason. (eg. if I scroll to the bottom of the content, then everything looks fine...but when I'm at the top it pushes everything down.)

    Guess I'd better start digging through NS CSS compatibility stuff....


Remove Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 10:27 AM.
Powered by vBulletin® Version 4.2.3
Copyright © 2020 vBulletin Solutions, Inc. All rights reserved.
vBulletin Skin By: PurevB.com