Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 1 of 1
  1. #1
    Junior Member
    Join Date
    Apr 2012
    Posts
    1
    Member #
    31336
    Hi there,

    I have attempted to speak with the Joomla support forum people, but have had no luck so i am trying my luck with anyone on here that might be a Joomla enthusiast.

    I have created a template, and it works (for the most part) I am trying to get the override to display the "Articles Category" module with a title, small description, and image to the left. I have the title and description working, but dont know how to display the image I have the code below but it doesnt seem to work.

    Code:
    <?php
    // no direct access
    defined('_JEXEC') or die;
    ?>
    <div class="BoxTop"><div class="BoxTopLeft"><!--KEEP NOTE--></div><h1><?php echo $module->title; ?></h1><div class="BoxTopRight"><!--KEEP NOTE--></div></div>
    <div class="BoxContent">
    <div class="Blog_Small">
    <ul>
        <?php foreach ($list as $item) : ?>
            <li>
            <a href="<?php echo $item->link; ?>">
            
            <?php if ($params->get('show_description_image') && $category->getParams()->get('image')) : ?>
                <img src="<?php echo $category->getParams()->get('image'); ?>"/>
            <?php endif; ?>
            
            <h3><?php echo $item->title; ?></h3>
            <?php if ($params->get('show_introtext')) :?>
                <?php echo $item->displayIntrotext; ?>
            <?php endif; ?>
            [ Read More ]
            </a>
        </li>
        <?php endforeach; ?>
    </ul>
    </div>
    </div>
    <div class="BoxBottom"><div class="BoxBottomLeft"><!--KEEP NOTE--></div><div class="BoxBottomRight"><!--KEEP NOTE--></div></div>
    <div class="Clear Space"><!--KEEP NOTE--></div>
    I have taken snippets of code from other modules, and the "Category Blog" component, but just cant get the ruddy image displayed. Its driving me insane!!!

    The site is here > http://www.djandyreed.co.uk

    Any assistance would be hugely appreciated.

    Thanks in advance,

    Andy

  2.  


Remove Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 10:49 AM.
Powered by vBulletin® Version 4.2.3
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
vBulletin Skin By: PurevB.com