Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 6 of 6
  1. #1
    Member Anant's Avatar
    Join Date
    Feb 2005
    Location
    Indore , India
    Posts
    50
    Member #
    9049
    hi all..

    well i installed apache and configured php according to the following step:

    • Stop Apache
    • Download zip file, rather than win installer. Php-4.3.1-Win32.zip
    • Extract contents to C:\php
    • Copy php.ini-dist to your Windows directory – Windows in XP, WINNT in 2000. Rename it as php.ini
    • Copy php4ts.dll from C:\php to C:\Windows\System32
    • Edit php.ini in a text editor, as shown in the next few lines
    • Find the line extension_dir = ./
    • Amend to extension_dir = "C:\php"
    • Find line doc_root = ./
    • Amend line to doc_root = "C:\Program Files\Apache Group\Apache2\htdocs"
    • Find line session.save_path = ./tmp
    • Amend line to session.save_path = "C:\tmp"
    • Make sure that the folder "C:\tmp" exists, or use another folder in the php.ini file.
    • Save and close php.ini
    • Open httpd.conf in text editor
    • Look for lines beginning LoadModule
    • Add these lines
    LoadModule php4_module “C:/php/sapi/php4apache2.dll”
    AddType application/x-httpd-php .php

    but it didn't worked and i am getting error when i start apache..the error says :
    the apache service could not be started
    the service didnot report an error

    pls tell em what to do ???

  2.  

  3. #2
    Senior Member rosland's Avatar
    Join Date
    Jul 2003
    Location
    Norway
    Posts
    1,944
    Member #
    2096
    It's actually very easy. I've had some pre-made script bundles give me problems (CMS's mostly), but both Apache and PHP are extremely easy to install.

    I assume you successfully installed Apache (and tested it) before trying to install PHP:

    For the Apache part, all you have to do is to alter the config file to include the ISAPI module found in PHP folder. (the installation file gives you the specifics)

    With regard to php, you have to copy all dll's (all files that does not start with "php_xxxx.dll", but rather "ntwdblib.dll" and their likes, to "system32".

    Your extension dir should (by default) be 'C:\php\ext' not 'C:\php'.

    Both systems comes with extensive/exhausting instructions. If you fail to get it up and running after readin through these, you should clear out (uninstall) everything, and go for one of the prebuildt packages you can download from the net.

    Can't remember the name (or link) to any of them now, but there are some links here at WDF, and a quick google should help you get some options.
    S. Rosland

  4. #3
    Member
    Join Date
    Jan 2005
    Posts
    97
    Member #
    8727
    Wouldn't you rather use the PHP module for Apache?

  5. #4
    Senior Member rosland's Avatar
    Join Date
    Jul 2003
    Location
    Norway
    Posts
    1,944
    Member #
    2096
    Quote Originally Posted by n3on
    Wouldn't you rather use the PHP module for Apache?
    The 'php module' for apache, is the ISAPI module. (runs as a service rather than a CGI executable)

    The ISAPI's are tailormade for the handling server. Hence the Apache ISAPI is a different module than the one you would run under IIS.
    S. Rosland

  6. #5
    Junior Member
    Join Date
    Aug 2003
    Posts
    8
    Member #
    2791
    Quote Originally Posted by Anant
    hi all..

    well i installed apache and configured php according to the following step:

    • Stop Apache
    • Download zip file, rather than win installer. Php-4.3.1-Win32.zip
    • Extract contents to C:\php
    • Copy php.ini-dist to your Windows directory – Windows in XP, WINNT in 2000. Rename it as php.ini
    • Copy php4ts.dll from C:\php to C:\Windows\System32
    • Edit php.ini in a text editor, as shown in the next few lines
    • Find the line extension_dir = ./
    • Amend to extension_dir = "C:\php"
    • Find line doc_root = ./
    • Amend line to doc_root = "C:\Program Files\Apache Group\Apache2\htdocs"
    • Find line session.save_path = ./tmp
    • Amend line to session.save_path = "C:\tmp"
    • Make sure that the folder "C:\tmp" exists, or use another folder in the php.ini file.
    • Save and close php.ini
    • Open httpd.conf in text editor
    • Look for lines beginning LoadModule
    • Add these lines
    LoadModule php4_module “C:/php/sapi/php4apache2.dll”
    AddType application/x-httpd-php .php

    but it didn't worked and i am getting error when i start apache..the error says :
    the apache service could not be started
    the service didnot report an error

    pls tell em what to do ???
    What version of apache are you trying to run?

    Have you checked your error logs?

    apache2\logs\error.log

  7. #6
    Member Anant's Avatar
    Join Date
    Feb 2005
    Location
    Indore , India
    Posts
    50
    Member #
    9049
    thanx people

    well i got the things working ...thanx for the help...tell me one thing pls..i wnat to run session in my php scripts ...do i have to change something in my any hhtpd.cong file or php.ini file...pls tell me that.


Remove Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 11:36 PM.
Powered by vBulletin® Version 4.2.3
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
vBulletin Skin By: PurevB.com