Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
  1. #1
    Senior Member hagen's Avatar
    Join Date
    Aug 2005
    Posts
    408
    Member #
    10882
    Liked
    1 times
    Hi, I am trying to display a jpg file in a popup window... I can do this fine on explorer but netscape doesnt want to play....

    Check out my design wwww.beach-huts.com
    hit search and click on one of the resulting thumbnail pictures....

    Explorer opens them fine netscape fails....

    I have contacted Netscape but dont seem to be getting an answer...

    any ideas / clues / insights?

    Cheers
    Hagen Rose: hagen(at)jxwd(dot)co(dot)uk
    JX Web Development, Bournemouth, Dorset...JXWD.co.uk

  2.  

  3. #2
    Senior Member
    Join Date
    May 2003
    Location
    UK
    Posts
    2,354
    Member #
    1326
    What happens?

    Does the popup pop and no image shown or no popup?

  4. #3
    Senior Member hagen's Avatar
    Join Date
    Aug 2005
    Posts
    408
    Member #
    10882
    Liked
    1 times
    the popup window, opens fine... i think it may be something to do with how netscape is capturing the data stream...

    have a look see

    -H
    Hagen Rose: hagen(at)jxwd(dot)co(dot)uk
    JX Web Development, Bournemouth, Dorset...JXWD.co.uk

  5. #4
    Senior Member
    Join Date
    May 2003
    Location
    UK
    Posts
    2,354
    Member #
    1326
    Can we see the code?

    Check your src in the image tag. Check the image its pointing to is valid

  6. #5
    Senior Member hagen's Avatar
    Join Date
    Aug 2005
    Posts
    408
    Member #
    10882
    Liked
    1 times
    Hi there, it works in explorer... invalid in what way?

    does anyone have an example (that works) of how to open an image from a database / file using function window.open, that works for Netscape!!

    cheers Hagen
    Hagen Rose: hagen(at)jxwd(dot)co(dot)uk
    JX Web Development, Bournemouth, Dorset...JXWD.co.uk

  7. #6
    Senior Member Fallout's Avatar
    Join Date
    Aug 2003
    Location
    Richmond, Virginia
    Posts
    543
    Member #
    2748
    Your site is down at the moment... but did you actually call Mozilla?


    Edit to maybe help:
    Code:
    <a href='#' onclick="window.open('yourimage.jpg','image',
    'left=20,top=20,width=500,height=500,toolbar=1,resizable=0');">View Image</a>
    This opens an image 500x500 with the back/forward/reload buttons with locked dimensions.

    I don't think there is any reason it wouldn't work in both IE and Firefox.

  8. #7
    Senior Member hagen's Avatar
    Join Date
    Aug 2005
    Posts
    408
    Member #
    10882
    Liked
    1 times
    Good Idea I will call Mozilla. I didnt know that was possible...
    Do you have a number handy?

    Cheers Hagen
    Hagen Rose: hagen(at)jxwd(dot)co(dot)uk
    JX Web Development, Bournemouth, Dorset...JXWD.co.uk

  9. #8
    Senior Member Fallout's Avatar
    Join Date
    Aug 2003
    Location
    Richmond, Virginia
    Posts
    543
    Member #
    2748
    Quote Originally Posted by hagen
    I have contacted Netscape but dont seem to be getting an answer...
    I interpreted this to mean you actually called them (which I don't think will work). Did you use the code that I posted? It should work for what you want.

  10. #9
    Senior Member hagen's Avatar
    Join Date
    Aug 2005
    Posts
    408
    Member #
    10882
    Liked
    1 times
    Ho there, I am trying to display a BLOG from a database not a .jpg directly, there in lies the problem, Netscape isnt reckognising it as a jpg when I use the open.window function... I am sending a jpg header, but the file extension is .php (necessary to run my server side code).

    IE I have:

    echo "<a STYLE=\"cursorointer; cursor: hand\" onClick=\"window.open('picture_frame.php?email_add ress=$email_address', '_blank', 'width=320,height=320' ); return false\"><img src=\"thumbnail_frame.php?email_address=$email_add ress\" border=\"0\" alt=\"click to see full size picture\"></a>";

    The thumbnail which is also handled in the same way is fine, but there as you can see I am not using open.window() to display that, where as I am with the actual picture....

    Cheers -Hagen
    Hagen Rose: hagen(at)jxwd(dot)co(dot)uk
    JX Web Development, Bournemouth, Dorset...JXWD.co.uk

  11. #10
    Senior Member Fallout's Avatar
    Join Date
    Aug 2003
    Location
    Richmond, Virginia
    Posts
    543
    Member #
    2748
    Does picture_frame.php print out any HTML or plain text? That could be the problem if it spits out something that is not part of the picture. Look for whitespace before/after your <?php and ?> tags.


Page 1 of 2 1 2 LastLast

Remove Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 06:23 PM.
Powered by vBulletin® Version 4.2.3
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
vBulletin Skin By: PurevB.com