Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 3 of 3
  1. #1
    Senior Member Stylise's Avatar
    Join Date
    Jul 2005
    Location
    Mount Martha, Australia
    Posts
    229
    Member #
    10679
    I've decided to upgrade tp PHP5, but can't get it to work with MySQL (It's beyond me why they took it out of the default installation).

    It's PHP Version 5.1.1.


    Configuration File (php.ini) Path C:\PHP\php.ini
    extension_dir c:/PHP/ext/ (tried c:\PHP\ext)


    I've uncommented extension=php_mysql.dll and have the dll files in c:/php/ext

    But still getting the 'PHP Startup: unable to load dynamic library 'c:\PHP\ext\php_mysql.dll...'' error

  2.  

  3. #2
    Senior Member rosland's Avatar
    Join Date
    Jul 2003
    Location
    Norway
    Posts
    1,944
    Member #
    2096
    Are you sure you've upgraded all the accompanying modules (system32 dll's and C:\php\ext dll's).
    It won't work with older versions of these libraries. The path is written with backslahes in my system and works fine.

    Have you made sure all traces of the old version are gone?
    Have you tried to run the php.ini-recommended to see if it works then? In that case, you just have to scrutinize your php.ini file, and set everything up from scratch.

    Are you running the ISAPI module under apache? Have you double checked that the conf file contains the right name for the module?
    Depending on what modules you're useing (gettext, exif, etc), the order of how they're listed is important. You have to rearrange the php.ini's extensions order. I learned this through reporting what I thought was a bug.
    S. Rosland

  4. #3
    Senior Member Stylise's Avatar
    Join Date
    Jul 2005
    Location
    Mount Martha, Australia
    Posts
    229
    Member #
    10679
    Got it working, had different versions of the installer and the binary for some reason.

    Cheers


Remove Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 07:30 AM.
Powered by vBulletin® Version 4.2.3
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
vBulletin Skin By: PurevB.com