Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 6 of 6
  1. #1
    Junior Member
    Join Date
    Sep 2010
    Posts
    5
    Member #
    23677
    Hi, i really would appreciate some help, i have this source i created a form on my website but nothing seems to reach my email on my server and it doesnt even forward it to my email which i use frequently.I was also told i need to put "SMTP", don't know how and where to put it.

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    <META HTTP-EQUIV="refresh" content="0;URL=thankyou.html">
    <title>Email Form</title>
    </head>

    <body>
    <?php
    $name=addslashes($_POST["name"]);
    $email=addslashes($_POST["email"]);
    $model=addslashes($_POST["model"]);
    $comments=addslashes($_POST["comments"]);

    // you can specify which email you want your contact form to be emailed to here

    $toemail = "info@wefixtv.com";
    $subject = "Comments from Server!";

    $headers = "MIME-Version: 1.0\n"
    ."From: \"".$name."\" <".$email.">\n"
    ."Content-type: text/html; charset=iso-8859-1\n";

    $body = "Name: ".$name."<br>\n"
    ."Email: ".$email."<br>\n"
    ."model: ".$model."<br>\n"
    ."Comments:<br>\n"
    .$comments;

    mail($toemail, $subject, $body, $headers);
    echo "Thanks for submitting your comments";
    ?>
    </body>
    </html>

    This is my website http://www.wefixtv.com.

    Any help will be gladly appreciated. Thanks

  2.  

  3. #2
    Senior Member medlington's Avatar
    Join Date
    Nov 2005
    Location
    Sheffield, UK
    Posts
    377
    Member #
    11968
    Liked
    4 times
    Hi,

    Having had a quick glance at the site and the form which I think is sending this info it looks like you have 3 different form tags around the form, can you post exactly the code your using for the form?

  4. #3
    Junior Member
    Join Date
    Sep 2010
    Posts
    5
    Member #
    23677
    Hi,

    Thanks for the tip i will correct that problem. Greatly appreciate the info.

  5. #4
    Senior Member Webzarus's Avatar
    Join Date
    May 2011
    Location
    South Carolina Coast
    Posts
    3,322
    Member #
    27709
    Liked
    770 times
    Take the meta refresh out of the head... Or give it a couple of seconds to allow the page to actually process...

    You should probably have a redirect at the bottom of the page instead of a meta refresh anyway... That way you know the page is processing when it passes off to the thank you page.

  6. #5
    Junior Member
    Join Date
    Sep 2010
    Posts
    5
    Member #
    23677
    Hi,
    Thanks to those who help me with this issue.Manage to resolve it with the information that was given by this forum. Gladly appreciated it.

  7. #6
    Senior Member Webzarus's Avatar
    Join Date
    May 2011
    Location
    South Carolina Coast
    Posts
    3,322
    Member #
    27709
    Liked
    770 times
    Glad you got it working


Remove Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 10:52 PM.
Powered by vBulletin® Version 4.2.3
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
vBulletin Skin By: PurevB.com