Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 8 of 8
  1. #1
    Junior Member SergioRibeiro's Avatar
    Join Date
    Sep 2016
    Location
    Florida USA
    Posts
    4
    Member #
    55274

    Product Images ceased to be displayed in Google Image Search

    We launched a new website design late February and since then 99% of our large product images do not show up on Google Image Search. We monitored the Image impressions after the launch of the new design, and the images impressions immediately dropped from nearly 30,000 to now 2,000. The only images (with the exception of a few products) that show up in the image search are the small thumbnails and not the full resolution images that the thumbnails link to. We did not mess with the image directories or any page directories... it was purely cosmetic. What could of triggered such drop?

    From my understanding Google bots should follow the thumbs href to the full-res image, and index it. Is this correct?

    We have been fighting this for months now, and no one can give us a straight answer. Images are a critical part of our business and this is a detremental blow to our business.
    I have a thread on Google's forum from May 2016 with some information of what other's have suggested: https://productforums.google.com/for...-place=starred

    We already made some suggested modifications such as adding titles to the large image in the lightbox, we made sure ALL images have 301 redirect to make sure they are served as https, and we also brought back the "View Detailed Images" link which we hid initially on the new design.

    The website experiencing this phenomenon is - tstindustries.com

    Thank you very much in advance for any input/help

    Sergio

  2.  

  3. #2
    Unpaid WDF Intern TheGAME1264's Avatar
    Join Date
    Dec 2002
    Location
    Not from USA
    Posts
    14,485
    Member #
    425
    Liked
    2783 times
    Your Google thread link isn't working, but as far as no one giving you a straight answer (I'm guessing from Google)...you won't get one. There's a very simple reason why you won't get one...you're not entitled to one. Neither am I. Neither is anyone else. Organic search traffic, regardless of method (web, images, etc.), is free...you don't pay for it, and they offer no promises. So if you're upset in any way over that, don't be. Your energy is much better spent elsewhere.

    With that said, some questions/comments:

    1) Did you change the URLs in any way besides the https change? Either the product URLs themselves or the image URLs? Or are they the original URLs in both cases?

    2) Do you have any error messages in Google Webmaster Tools (specifically 404 or 500 errors)?

    3) You don't have a robots.txt file. You may want to put one in, if for no other reason than to guide bots. You may also want to consider an image sitemap if you haven't used one.

    https://www.google.com/schemas/sitemap-image/1.1/

    4) You're using X-Cart now. Were you using it before?

    5) If you had old images, were any of your images linked from other sites (hotlinked, specifically)? You'll want to redirect users in those instances.

    There are a few places to start, but this is one of those cases where you won't find a single answer. It will be several things that got missed or not taken fully into consideration.
    If I've helped you out in any way, please pay it forward. My wife and I are walking for Autism Speaks. Please donate, and thanks.

    If someone helped you out, be sure to "Like" their post and/or help them in kind. The "Like" link is on the bottom right of each post, beside the "Share" link.

    My stuff (well, some of it): My bowling alley site | Canadian Postal Code Info (beta)

  4. #3
    Junior Member SergioRibeiro's Avatar
    Join Date
    Sep 2016
    Location
    Florida USA
    Posts
    4
    Member #
    55274
    My apologies, here is the correct link: https://productforums.google.com/for...=mydiscussions

    Answers to your questions:

    1) No changes to the URLs were made... 95% of the redesign was cosmetic only, not much reengineering was made.

    2) A few Soft 404, but nothing mentioning any particular images. More so about pages that no longer exist.

    3) In the last few days I got a bunch of suggestions for a images sitemap. This is something I will be trying out.

    4) Yes. We were using X-Cart when the images were showing up in the results.

    5) Yes we have old images, but 99% of our images reside in our server. Especially product images...100% of them reside in our server.

    THANK YOU SO MUCH FOR YOUR HELP. MUCH, MUCH APPRECIATED.

    Serge
    Last edited by SergioRibeiro; Sep 26th, 2016 at 07:13 AM.

  5. #4
    Unpaid WDF Intern TheGAME1264's Avatar
    Join Date
    Dec 2002
    Location
    Not from USA
    Posts
    14,485
    Member #
    425
    Liked
    2783 times
    Okay...when you say "not much reengineering was made", what was done (general terms)?
    If I've helped you out in any way, please pay it forward. My wife and I are walking for Autism Speaks. Please donate, and thanks.

    If someone helped you out, be sure to "Like" their post and/or help them in kind. The "Like" link is on the bottom right of each post, beside the "Share" link.

    My stuff (well, some of it): My bowling alley site | Canadian Postal Code Info (beta)

  6. #5
    Junior Member SergioRibeiro's Avatar
    Join Date
    Sep 2016
    Location
    Florida USA
    Posts
    4
    Member #
    55274
    What I meant was, the changes were 95% cosmetic (CSS & JS). The PHP/Smarty edits we made were minimal.

  7. #6
    Unpaid WDF Intern TheGAME1264's Avatar
    Join Date
    Dec 2002
    Location
    Not from USA
    Posts
    14,485
    Member #
    425
    Liked
    2783 times
    PHP/Smarty edits probably won't affect it. It's more along the lines of "did you change URLs in any way?" Or did you change navigation/site structure? Did any pages get buried (although with your particular navigation I doubt it)?

    One other thing: did the number of pages indexed go down in Google Webmaster Tools? If it did, then part of your reason may lie there.
    If I've helped you out in any way, please pay it forward. My wife and I are walking for Autism Speaks. Please donate, and thanks.

    If someone helped you out, be sure to "Like" their post and/or help them in kind. The "Like" link is on the bottom right of each post, beside the "Share" link.

    My stuff (well, some of it): My bowling alley site | Canadian Postal Code Info (beta)

  8. #7
    Junior Member SergioRibeiro's Avatar
    Join Date
    Sep 2016
    Location
    Florida USA
    Posts
    4
    Member #
    55274
    The structure was not changed and we didn't change the URLs. Also our indexed pages stayed pretty much the same. BUT as I mentioned we did not have an images sitemap. Yesterday morning I created one for a single product just to test it out...The product thumbnails get index, but the large images don't. I checked the large images directory to see if it was a permissions issue, the permissions look fine - 755.

    But i'm thinking the large images would get indexed from the images sitemap because, they are being called from the thumbnails anchor's href. Here is the structure:

    <a href="LINK TO LARGE IMAGE">
    <img src="SMALL THUMBNAIL" />
    </a>

    So I don't think the images sitemap wouldn't accept the href as an acceptable image src. Are there ways to tell the bots to follow the href in the images sitemap?

    Thanks.
    Last edited by SergioRibeiro; Sep 27th, 2016 at 11:43 AM.

  9. #8
    Unpaid WDF Intern TheGAME1264's Avatar
    Join Date
    Dec 2002
    Location
    Not from USA
    Posts
    14,485
    Member #
    425
    Liked
    2783 times
    A day won't tell you all that much. I haven't linked images the way that you have, but I'd give it at least a week and see if the large image shows up. If not, you'll probably want to come up with another way to display the large images. Maybe create a large image gallery section or something.
    If I've helped you out in any way, please pay it forward. My wife and I are walking for Autism Speaks. Please donate, and thanks.

    If someone helped you out, be sure to "Like" their post and/or help them in kind. The "Like" link is on the bottom right of each post, beside the "Share" link.

    My stuff (well, some of it): My bowling alley site | Canadian Postal Code Info (beta)


Remove Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 08:34 AM.
Powered by vBulletin® Version 4.2.3
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
vBulletin Skin By: PurevB.com