Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 7 of 7
  1. #1
    Member VegaLA's Avatar
    Join Date
    May 2004
    Posts
    70
    Member #
    6035
    Hi all.
    I'm trying to set up a website on the webserver here
    that already hosts our own website but now I want to test to see if we can start hosting sites for clients. I have set up a test site but when I try to get it up on the browser I get this error message.

    "Directory Listing Denied
    This Virtual Directory does not allow contents to be listed."

    I have never done this before so i'm not completly surprised, just disapointed, but could anyone point me onto the right tracks ?

    Mitch....

  2.  

  3. #2
    Senior Member
    Join Date
    May 2003
    Location
    UK
    Posts
    2,354
    Member #
    1326
    It depends, but is it a valid directory?

    Im not that hot on servers, but maybe that is your hosts message when a page is requested that does not exist.

    Or, maybe your host does not allow users to view a folder structure. Try putting a index.htm file in that folder and see if that gets shown.

  4. #3
    Member VegaLA's Avatar
    Join Date
    May 2004
    Posts
    70
    Member #
    6035
    Quote Originally Posted by bfsog
    It depends, but is it a valid directory?

    Im not that hot on servers, but maybe that is your hosts message when a page is requested that does not exist.

    Or, maybe your host does not allow users to view a folder structure. Try putting a index.htm file in that folder and see if that gets shown.
    Yup, it has a index.html page in there which i created just for testing but it does'nt display. I have checked my settings for the Default website from IIS 6 >> Servername >> Web sites and it is the same. I'm not sure what to do next ?

  5. #4
    Junior Member
    Join Date
    Dec 2004
    Posts
    9
    Member #
    8527
    You might need to check the IIS setting again. there is an option to allow folder directory listing... Dig around a bit you will find it... allow the directory listing to and you should be able to see all the contents of the directory or file online... if not your not setup correctly.

  6. #5
    Member VegaLA's Avatar
    Join Date
    May 2004
    Posts
    70
    Member #
    6035
    Quote Originally Posted by Markdamo
    You might need to check the IIS setting again. there is an option to allow folder directory listing... Dig around a bit you will find it... allow the directory listing to and you should be able to see all the contents of the directory or file online... if not your not setup correctly.
    Cheers... getting there. i found the checkbox for dir browing, checked it and tried again and I now get a list of the files but although the one file in there is index.html it just lists the file instead of showing the html file as a normal webpage.

    Mitch.........

  7. #6
    Senior Member jbagley's Avatar
    Join Date
    Sep 2004
    Location
    Cape Town
    Posts
    845
    Member #
    7422
    There is also an tab in ISS called "documents". There you can specify the home page that must load when you browse to the site.

  8. #7
    Member VegaLA's Avatar
    Join Date
    May 2004
    Posts
    70
    Member #
    6035
    Thank you, I actually added the index html to that list but when I just checked it it was'nt there. Anyway added it and tried it and it works great, thanks everyone for your help.

    Mitch........


Remove Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 01:11 PM.
Powered by vBulletin® Version 4.2.3
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
vBulletin Skin By: PurevB.com