Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 1 of 1
  1. #1
    Junior Member
    Join Date
    Nov 2005
    Posts
    1
    Member #
    11931
    I'm running ASP.Net and Access DB together on a site on an Apache server. I keep getting the System.Data.OleDb.oleDbException: Unspecified error. This is happening randomly due to my permissions set wrong on a Temp file.
    I have all the db files and everything in the correct folders and the site will work for a while until it crashes to this error.

    I used this article for help, it states the problem and a resolution
    http://support.microsoft.com/default...b;EN-US;825738

    I'm having problems locating my Temp file. I have mod-aspdotnet 2.0.0 running to allow asp.net on apache.
    I'm not getting the expected proerties box when r-click and open properites on any folders that I try to set persmissions on. Instead of general/security/summary w/permission check boxes I get a properties box with general/sharing/websharing/customize/ looking like this:
    [img]
    http://www.rlwwebdesigns.com/File.htm
    [/img]

    I desided to look for a way to access Apache and IIS from the same machine at the same time having both servers live and taking incoming hits together (so I could put asp sites on IIS and leave rest on Apache)

    I came up with this from some help (Setting mod-proxy)
    I went in Apache http.config and uncommented some of the proxy server directives and put the code here how it looks in my http.config. Not sure if I opend the right code, to much of it or if I need more. ??

    Code:
    # Proxy Server directives. Uncomment the following lines to
    # enable the proxy server:
    #
    <IfModule mod_proxy.c>
    ProxyRequests On
    #
    <Proxy *>
    Order deny,allow
    Deny from all
    # Allow from .your-domain.com
    Allow from .robertwallaceii.com
    </Proxy>
    
    ProxyPass /Inetpub/wwwroot/ http://localhost:8888/
    ProxyPassReverse /Inetpub/wwwroot/ http://localhost:8888/
    
    #
    # Enable/disable the handling of HTTP/1.1 "Via:" headers.
    # ("Full" adds the server version; "Block" removes all outgoing Via: headers)
    # Set to one of: Off | On | Full | Block
    #
    #ProxyVia On
    
    #
    # To enable the cache as well, edit and uncomment the following lines:
    # (no cacheing without CacheRoot)
    #
    #CacheRoot "c:/apachefriends/xampp/apache/proxy"
    #CacheSize 5
    #CacheGcInterval 4
    #CacheMaxExpire 24
    #CacheLastModifiedFactor 0.1
    #CacheDefaultExpire 1
    #NoCache a-domain.com another-domain.edu joes.garage-sale.com
    
    #</IfModule>
    # End of proxy directives.

    I didn't see in mod_rewrite areas to uncomment.

    These are the Modules that I have loaded that seemed to pertain to proxy and mod_rewrite.
    Code:
    #Example
    # LoadModule foo_module modules/mod_foo.so
    #
    LoadModule proxy_module modules/mod_proxy.so
    LoadModule proxy_connect_module modules/mod_proxy_connect.so
    LoadModule proxy_http_module modules/mod_proxy_http.so
    LoadModule proxy_ftp_module modules/mod_proxy_ftp.so
    
    LoadModule rewrite_module modules/mod_rewrite.so

    Here is my virtual host area. I copied the code that was posted to help me and then added my info in the blah spaces.
    Code:
    #:8888 ASP.NET SITES FROM IIS Windows#
    <VirtualHost *:80>
    ServerAdmin webmaster@blah.com
    ServerName www.blah.com
    ServerAlias www.blah.com *.blah.com
    LogLevel warn
    
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteRule ^/(.*) \
    http://localhost:8888/$1 [L,P]
    </IfModule>
    </VirtualHost>
    Getting the error here:
    http://localhost:8888/$1 [L,P]

    I'm not getting an error # in the screen prompts when I restart only line number and this:
    I get "Invalid command 'http://localhost:8888/$1' perhaps misspelled or defined by a module not included in the server configuration

    I was getting 'http://localhost:8888' as the line error when I took out the /$1

    Any ideas here?

    Thanks
    Bob W.

  2.  


Remove Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 10:03 AM.
Powered by vBulletin® Version 4.2.3
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
vBulletin Skin By: PurevB.com