If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 1 of 1
  1. #1
    Member lew1s's Avatar
    Join Date
    Oct 2013
    Member #
    2 times

    VPS nging - wordpress rich permlinks not working

    I have VPS with nginx and have some subdomains there. Mostly Wordpress website and one Magento. Magento website is working fine but wordpress cant use rich permlinks. I am getting Server error. Can you please tell me what configuration file to use?

    This is my file in etc/nginx/sites-enabled/wordpress

    server {
    listen 80;

    root /var/www/;

    ## rewrite to
    if ($http_host != "") {
    rewrite ^ $scheme://$request_uri permanent;

    location / {
    index index.html index.php; ## Allow a static html file to be shown first
    try_files $uri $uri/ @handler; ## If missing pass the URI to Magento's front handler
    expires 30d; ## Assume all files are cachable

    ## Locations should be hidden
    location /app/ { deny all; }
    location /includes/ { deny all; }
    location /lib/ { deny all; }
    location /media/downloadable/ { deny all; }
    location /pkginfo/ { deny all; }
    location /report/config.xml { deny all; }
    location /var/ { deny all; }

    location /var/export/ { ## Allow admins only to view export folder
    auth_basic "Restricted"; ## Message shown in login window
    auth_basic_user_file /var/www/.htpasswd; ## See /etc/nginx/htpassword
    autoindex on;

    ## Disable .htaccess and other hidden files
    location ~ /\. {
    deny all;
    access_log off;
    log_not_found off;

    location @handler { ## Magento uses a common front handler
    rewrite / /index.php;

    location ~ .php/ { ## Forward paths like /js/index.php/x.js to relevant handler
    rewrite ^(.*.php)/ $1 last;
    location ~ .php$ { ## Execute PHP scripts
    if (!-e $request_filename) { rewrite / /index.php last; } ## Catch 404s that try_files miss

    expires off; ## Do not cache dynamic content
    fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
    fastcgi_param MAGE_RUN_CODE default; ## Store code is defined in administration > Configuration > Manage Stores
    fastcgi_param MAGE_RUN_TYPE store;
    include fastcgi_params; ## See /etc/nginx/fastcgi_params



Remove Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Tags for this Thread

All times are GMT -6. The time now is 10:55 PM.
Powered by vBulletin® Version 4.2.3
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
vBulletin Skin By: