Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 5 of 5
  1. #1
    Junior Member
    Join Date
    Oct 2003
    Posts
    2
    Member #
    3747
    Ok here is the deal... I have been running a website on my own webserver (Red Hat 9 with Apache) for quite some time now. However, now I want to add another website with it's own domain name so I set up apache for name-based virtual hosting. I made two directories in the /var/www/html/ directory one called abc for my original site and one called xyz for my new site. Then I used the httpd server configuration thing in RH9 to set up apache to refer to the directories. My original site works great (at first it was missing a few images but after cp-ing them into the new directory all is well). The problem is with my new website I keep getting the darn Apach Test Page. I dont' understand what the problem is as I have them set up the same way. In the document root spot I have /var/www/html/abc for the first one and /var/www/html/xyz for the second. Now what about the thing that says default directory settings and has some selection for all hosts access and allow htaccess? Does that have something to do with it? I tried setting that directory to the document root directory as well and still nothing. I have been trying to figure this out for hours now, please help! Everything I have read leaves me to believe that I just type in what directory I want --chmod it and then "poof" it should be online. So what is the problem here? My first site runs fine ????
    --Phil

    Oh wait.... If I type in the www.mywebsite.com/index.html it will go to my website but if I just type in www.mywebsite.com it shows the apache test page. This is ridiculous...

  2.  

  3. #2
    Junior Member
    Join Date
    Dec 2003
    Posts
    1
    Member #
    4215
    HI Flipside,

    I had the exactly same problem. I am a system programmer, so I work with the method of hit 'n trial. So i don't know what exactly solved the problem, but the solution was in the apache conf file (httpd.conf). The problem was probably with the ServerName directive or the DocumentRoot directive in the 'main server' configuration of the conf file.

    I hope this helps, if not, lemme know how far could u go.

    ....................Ams_Genius.................... .

  4. #3
    Senior Member splufdaddy's Avatar
    Join Date
    Feb 2003
    Location
    Boston, MA
    Posts
    4,488
    Member #
    735
    I took a network admin class last semester, and we had a lot of problems with Apache's GUI. The problem was that although we made changes in the nice graphical interface, these changes weren't made in the actual files that mattered. Editing these files by hand fixed the problem.

  5. #4
    Junior Member
    Join Date
    May 2003
    Location
    Cambridgeshire, UK
    Posts
    29
    Member #
    1544
    Also try looking at the default filenames that apache picks up. For your new site the DirectoryIndex (i think thats what it's called) could be missing or set as the standard apache index.html.var.

    Hope that helps.

  6. #5
    Senior Member Gemini ISP's Avatar
    Join Date
    Oct 2003
    Posts
    243
    Member #
    3510
    use the following info as a guide for your httpd.conf file -- this is how u set multiple virtual host

    <VirtualHost 000.000.0.000> --- this is the ip for the virtual host 192.168.x.x
    ServerAlias www.domain.net domain.net
    ServerAdmin webmaster@domain.net
    DocumentRoot /home/test/public_html--- this is where u set ur directory
    ServerName www.domain.net --- use if u have a servername
    ScriptAlias /cgi-bin/ /home/test/public_html/cgi-bin/ --if u have a cgi-bin folder
    </VirtualHost>

    this info goes in the end of the httpd.conf file

    enjoy WDF
    added note take out the notes where is says
    ---blah blah blah they are my comments
    Mas
    Gemini-isp.com


Remove Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 03:39 AM.
Powered by vBulletin® Version 4.2.3
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
vBulletin Skin By: PurevB.com