Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 5 of 5
  1. #1
    Junior Member Jessie's Avatar
    Join Date
    May 2011
    Posts
    7
    Member #
    27891
    Hi everyone.

    Ok, I just want to start off by saying that I am pretty new to all of this and I am not 100% sure why I am having this particular issue, but I want to see if anyone here might be able to offer me some advice.

    I have recently created my website in Adobe Dreamweaver CS5. When I preview the website in internet explorer, everything works fine. Today I uploaded my website, following the directions given by my hosting provider (crazydomains) by creating a network pace and uploading everything via ftp? and the index page works perfectly fine, all the buttons and images work, but when you move to any of the other webpages the background and text is there, but the images are missing and some of the links don't work properly.

    I contacted the technical support team from crazydomains and they said that there was probably something wrong with my path source code. I'm not really sure what this means or why the index page works fine, yet none of the other pages do.

    My website: http://www.jmphotography.net.au/

    Any advice would be greatly appreciated.

  2.  

  3. #2
    Unpaid WDF Intern TheGAME1264's Avatar
    Join Date
    Dec 2002
    Location
    Not from USA
    Posts
    14,485
    Member #
    425
    Liked
    2783 times
    Your host is absolutely right in this case. I don't think this is your fault as such...this looks like Dr*amw*av*r bastardizing code and concepts again.

    What's happening is that you're referencing parent paths to files based on where they are on your machine's hard drive. Besides causing a real potential security issue, your server will have different paths to things so they won't work.

    Here's an example of a path to something you have:
    Code:
    ../../../../My Documents/Unnamed Site 2/pricing.jpg
    Now, "My Documents" doesn't actually exist on the crazydomains server at all, at least not anywhere that you're putting a site.

    Here's what you should do.

    1) Take every one of your subpages and put them in the same folder as your home page (for clarity's sake, we're calling this "Site Folder"). Don't put them in a "web pages" folder. Keep them all together. You're going to want to keep your stuff organized. That's your deeper problem, and it's the reason your site isn't functionin the way you expect it would.

    2) Put all of your images in a subfolder of "Site Folder". Again, you want all of your site's information in the same folder and subfolders.

    3) Reference your images in code as "(subfolder)/(image)".

    Again, your problem in this case relates to that of organization. You need to keep all your stuff in one section of your hard drive...and ideally, not your desktop or documents folder (that just creates clutter when you don't need to).
    Jessie likes this.
    If I've helped you out in any way, please pay it forward. My wife and I are walking for Autism Speaks. Please donate, and thanks.

    If someone helped you out, be sure to "Like" their post and/or help them in kind. The "Like" link is on the bottom right of each post, beside the "Share" link.

    My stuff (well, some of it): My bowling alley site | Canadian Postal Code Info (beta)

  4. #3
    Junior Member Jessie's Avatar
    Join Date
    May 2011
    Posts
    7
    Member #
    27891
    Thanks so much for the advice.

    I have follwed the steps you gave, gotten everything more organized (which is something I should be doing a lot more often) and off the desktop and it all seems to be working Still a few tweaks to do with my galleries but at least it is useable now.

    Thanks so much again for your help, really appreciate it

  5. #4
    Unpaid WDF Intern TheGAME1264's Avatar
    Join Date
    Dec 2002
    Location
    Not from USA
    Posts
    14,485
    Member #
    425
    Liked
    2783 times
    Cool. No problem!
    If I've helped you out in any way, please pay it forward. My wife and I are walking for Autism Speaks. Please donate, and thanks.

    If someone helped you out, be sure to "Like" their post and/or help them in kind. The "Like" link is on the bottom right of each post, beside the "Share" link.

    My stuff (well, some of it): My bowling alley site | Canadian Postal Code Info (beta)

  6. #5
    Banned
    Join Date
    May 2011
    Location
    Fairfax, CA
    Posts
    2,036
    Member #
    28003
    Liked
    126 times
    Glad you got it figured it out.


Remove Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Search tags for this page

how to upload an image to crazy domains

Click on a term to search for related topics.
All times are GMT -6. The time now is 04:35 AM.
Powered by vBulletin® Version 4.2.3
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
vBulletin Skin By: PurevB.com