Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 3 of 3
  1. #1
    Junior Member
    Join Date
    Jul 2016
    Posts
    2
    Member #
    54751

    Google Pagespeed gives me low rating for a blank page?

    Dear all,
    Many thanks for allowing me to join the forum. I'm currently dealing with an issue and have very little technical background so would really appreciate any pointers on this.

    I use Xara Web Designer 11 Premium WYSIWYG software. I've made a website and then I made different 'variants' to deal with responsive web design as best as the Xara software lets me.

    When I tested my pages I was getting very poor loading speed times. I checked using Google PageSpeed and was getting 35/100. Someone on the Xara forum said that because Xara creates variants (different 'versions' of each web page) that this would slow down my loading speed. Last night I tried deleting variants and, yes, the speed rating increased on Google PageSpeed. Eventually my testing saw me have one page variant, but still with a very low rating. I then deleted all the images and it was still slow. My test ended up with a blank page...and Google was giving me a 59/100 rating.

    So my question is, what should I look to do?

    Here's the 'blank page' - nothing on it whatsoever aside from favicon. No menus, no pictures, no text.
    Edinburgh tours, Greyfriars Kirkyard tours, Canongate tours with Historic Edinburgh Tours. This gets 59/100 for mobile on PageSpeed

    Here's the 'loaded' version
    Edinburgh tours, Greyfriars Kirkyard tours, Canongate tours with Historic Edinburgh Tours. This gets 36/100

    So what do I need to do now? I assumed that a blank page would get a rating of 100/100 and subsequently adding images would decrease it each time an image was added.

    Apologies if I'm asking something which has been covered to death (I did look but possibly missed it as I really now don't know what I'm doing).

    Any help is greatly appreciated.
    Yours,
    Robert

  2.  

  3. #2
    Unpaid WDF Intern TheGAME1264's Avatar
    Join Date
    Dec 2002
    Location
    Not from USA
    Posts
    14,485
    Member #
    425
    Liked
    2783 times
    It's not a blank page. THIS:
    Code:
    <!DOCTYPE html>
    <html>
    <head>
    <title>Blank Page</title>
    </head>
    <body>
    </body>
    </html>
    is a blank page. Just because you have no content on the page doesn't mean that it's blank. In your particular case, you're calling multiple JS files in the head of your document along with several CSS files. That's one of the things that is slowing it down...there are others, but this is a starting point and will help you to understand some of what to look for (some of the other stuff is more advanced).

    https://developers.google.com/speed/...o.uk%2Ftest%2F <-- the best thing you can do is view the details of your PageSpeed results and figure out what to adjust from there.
    If I've helped you out in any way, please pay it forward. My wife and I are walking for Autism Speaks. Please donate, and thanks.

    If someone helped you out, be sure to "Like" their post and/or help them in kind. The "Like" link is on the bottom right of each post, beside the "Share" link.

    My stuff (well, some of it): My bowling alley site | Canadian Postal Code Info (beta)

  4. #3
    Junior Member
    Join Date
    Jul 2016
    Posts
    2
    Member #
    54751
    Thank you!
    I appreciate your time taken in replying. I've still go a 'slow' site but last night I upgraded my 1and1 package with their CDN Plus and the weird effects I was having before hand (images not appearing, background colour boxes not showing, buttons missing) have disappeared. I'm sure I need to deal with this more effectively but, for now, this seems to have helped a lot.
    Thank you for helping.
    Yours,
    Robert


Remove Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 07:59 PM.
Powered by vBulletin® Version 4.2.3
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
vBulletin Skin By: PurevB.com