Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 5 of 5
  1. #1
    Junior Member
    Join Date
    Sep 2011
    Location
    Atlanta, GA
    Posts
    9
    Member #
    29434
    Hey guys, I'm pulling my hair out over here. I hope you can help. It would be much appreciated.

    I'm customizing a wordpress theme and have an email capture form plugin (WP Email Capture) with name-email-submit button. The form is very basic and I am changing the submit button to an image rollover button. I am working with MAMP on a local host to view instead of being live.

    I could be going about this all wrong because I'm a bit of a newb.

    My problem:

    The rollover and the button works but I have this damn border around the button an it is driving me crazy! I can't get rid of the border. Also, The button shows up like it can't find the image. Why is this happening? When I remover the src="my image" it show the text "submit" and the border. What do I need to do here? lol

    Code:
    <label class="wp-email-capture-name">Name:</label> <input name="wp-email-capture-name" size="42" type="text" class="wp-email-capture-name"><br/>
    
    <label class="wp-email-capture-email">Email:</label> <input name="wp-email-capture-email" size="42" type="text" class="wp-email-capture-email"><br/>
    
    <input type="hidden" name="wp_capture_action" value="1">
    
    <input name="input" type="image" height="37" width="115" src="subscribebtn.jpg"  class="wp-email-capture-submit" font-size="0" line-height="0" border="0" value="" >
    
    </form>
    Code:
    #wp_email_capture {
    
    }
    
    #wp_email_capture label {
    text-decoration: none;
    border:none;
    }
    
    #wp_email_capture input {
    margin: 15px 0 0 0;
    line-height: 15px;
    text-decoration: none;
    border:none;
    
    }
    
    #wp_email_capture_2 {
    
    }
    
    #wp_email_capture_2 label {
    
    }
    
    #wp_email_capture_2 input {
    
    }
    
    input[type=image] {
    height: 37px;
    width: 115px;
    background-image:url(../../plugins/wp-email-capture/inc/subscribebtn.jpg);
    text-decoration: none;
    border:0;
    display: block;
    text-indent: -999em;
    }
    input:hover[type=image] {
    height: 37px;
    width: 115px;
    background-image:url(../../plugins/wp-email-capture/inc/subscribebtnon.jpg);
    text-decoration: none;
    border:0;
    display: block;
    text-indent: -999em;
    }
    This is the result


    This is what is looks like when I remover the src="myimage" from the html


    Any help would be amazing. Thanks in advance!

  2.  

  3. #2
    WDF Staff AlphaMare's Avatar
    Join Date
    Oct 2009
    Location
    Montreal, Canada
    Posts
    4,570
    Member #
    20277
    Liked
    878 times
    I'm moving this to the Wordress forum. You'll stand a better chance of a good answer there, I think.
    Good design should never say "Look at me!"
    It should say "Look at this." ~ David Craib


    http://digitalinsite.ca ~ my current site . . info@digitalinsite.ca ~ my email

    If you feel that someone's post helped you fix your problem, answered your question, or just made you feel better, feel free to "Like" their post. The "Like" link is at the bottom right of each post, along side the "reply" link. And if you are being helped here, try to help someone else - pass it on!

  4. #3
    WDF Staff AlphaMare's Avatar
    Join Date
    Oct 2009
    Location
    Montreal, Canada
    Posts
    4,570
    Member #
    20277
    Liked
    878 times
    Can you please post a link so I can see your code in place?
    Good design should never say "Look at me!"
    It should say "Look at this." ~ David Craib


    http://digitalinsite.ca ~ my current site . . info@digitalinsite.ca ~ my email

    If you feel that someone's post helped you fix your problem, answered your question, or just made you feel better, feel free to "Like" their post. The "Like" link is at the bottom right of each post, along side the "reply" link. And if you are being helped here, try to help someone else - pass it on!

  5. #4
    Junior Member
    Join Date
    Sep 2011
    Location
    Atlanta, GA
    Posts
    9
    Member #
    29434
    Ok thank you! I am loading the site right now so it will be viewable live. I will post a link soon.

    I ran inspect element in chrome and it seems the src image link is broken in the html but I don't understand why since it is set up exactly like my other images.

  6. #5
    Junior Member
    Join Date
    Sep 2011
    Location
    Atlanta, GA
    Posts
    9
    Member #
    29434
    Finally got it. WOW, for some reason I had to include the entire file path for this image and I didn't have to for the others. I don't know why but it worked! This can be closed. Thanks!


Remove Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 02:15 PM.
Powered by vBulletin® Version 4.2.3
Copyright © 2020 vBulletin Solutions, Inc. All rights reserved.
vBulletin Skin By: PurevB.com