Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 4 of 4
Like Tree1Likes
  • 1 Post By AlphaMare

Thread: Insert logo in Wordpress Header

  1. #1
    Junior Member megatype's Avatar
    Join Date
    Mar 2014
    Posts
    3
    Member #
    38706

    Insert logo in Wordpress Header

    Just trying out customizing a theme.

    I need to insert a header logo.

    I added from "<p align=left... to 1px; /> that I found on another forum site and now there is a blank box where my image should be. I'm missing something but I don't know what. Should I be editing my css as well? Please advise.

    Here is the section from my header.php

    <div class="head-wrap">
    <hgroup id="site-heading">
    <p align=left style="margin-top: 1px; margin-right: 1px;"><img src=".images/logo3s.png" width="573" height="100" title="Logo" margin-right: 1px; /></p>
    <h1 id="site-title"><a href="<?php echo home_url( '/' ); ?>" title="<?php echo esc_attr( get_bloginfo( 'name', 'display' ) ); ?>" rel="home"><?php bloginfo( 'name' ); ?></a></h1>
    <h2 id="site-description"><?php bloginfo( 'description' ); ?></h2>
    </hgroup>

    </div>

  2.  

  3. #2
    WDF Staff AlphaMare's Avatar
    Join Date
    Oct 2009
    Location
    Montreal, Canada
    Posts
    4,570
    Member #
    20277
    Liked
    878 times
    Try using the absolute path to the image - that should do it.

    Are you ever going to update the theme? If so, be sure to save the code somewhere so you can fix it if the update overwrites it. (This is why I use child themes).
    megatype likes this.
    Good design should never say "Look at me!"
    It should say "Look at this." ~ David Craib


    http://digitalinsite.ca ~ my current site . . info@digitalinsite.ca ~ my email

    If you feel that someone's post helped you fix your problem, answered your question, or just made you feel better, feel free to "Like" their post. The "Like" link is at the bottom right of each post, along side the "reply" link. And if you are being helped here, try to help someone else - pass it on!

  4. #3
    Junior Member megatype's Avatar
    Join Date
    Mar 2014
    Posts
    3
    Member #
    38706
    Thank you so much for reply. I did add the complete path but I don't see a change. I even looked in incognito mode so the cache wasn't the problem just in case. This is what the code looks like now. The folder before wp-content is "webroot", should I include that as well?

    <div class="head-wrap">
    <hgroup id="site-heading">
    <p align=left style="margin-top: 1px; margin-right: 1px;"><img src=".wp-content/themes/newschannel-child/library/images/logo3s.png" width="573" height="100" title="Logo" margin-right: 1px; /></p>
    <h1 id="site-title"><a href="<?php echo home_url( '/' ); ?>" title="<?php echo esc_attr( get_bloginfo( 'name', 'display' ) ); ?>" rel="home"><?php bloginfo( 'name' ); ?></a></h1>
    <h2 id="site-description"><?php bloginfo( 'description' ); ?></h2>
    </hgroup>

    </div>

    I think I did make a child theme. Or at least I copied the entire contents of the original theme into a separate one and made my changes there. I appreciate anything you can share with me on this.

  5. #4
    WDF Staff AlphaMare's Avatar
    Join Date
    Oct 2009
    Location
    Montreal, Canada
    Posts
    4,570
    Member #
    20277
    Liked
    878 times
    You still have not used the absolute path - you have ".wp-content/themes/newschannel-child/library/images/logo3s.png"

    first of all I don't know why you have a "." before the "wp-content/etc/etc", but in any case, an absolute path would be
    "
    http://www.yourdomain.com/wp-content/themes/newschannel-child/library/images/logo3s.png"


    Can you post a link to the site so I can take a look at the code?

    Good design should never say "Look at me!"
    It should say "Look at this." ~ David Craib


    http://digitalinsite.ca ~ my current site . . info@digitalinsite.ca ~ my email

    If you feel that someone's post helped you fix your problem, answered your question, or just made you feel better, feel free to "Like" their post. The "Like" link is at the bottom right of each post, along side the "reply" link. And if you are being helped here, try to help someone else - pass it on!


Remove Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Tags for this Thread

All times are GMT -6. The time now is 08:02 PM.
Powered by vBulletin® Version 4.2.3
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
vBulletin Skin By: PurevB.com